Devolutions.Utils Namespace

Devolutions Utils reference library
Devolutions.Utils Namespace
Namespaces ► Devolutions.Utils
Declaration Syntax
C# Visual Basic Visual C++
namespace Devolutions.Utils
Namespace Devolutions.Utils
namespace Devolutions.Utils
Types
All Types Classes Enumerations
Icon | Type | Description
 | ArrayUtils | This class contains the array utility functions.
 | AspNetUtils | This class contains the ASP.NET utility functions.
 | BinarySerializationUtils | This class contains the serialization utility functions.
 | DataSetUtils | This class contains dataset utility functions.
 | DateUtils | This class contains the date utility functions.
 | FileUtils | This class contains the file utility functions.
 | IISUtils | This class contains the IIS utility functions.
 | ImageUtils | This class contains the Image utility functions.
 | LogUtils | Basic file logger with multithreading support
 | OfficeUtils | This class contains the basic Office utility functions.
 | ReflectionUtils | This class contains the reflection utility functions.
 | RegistryUtils | This class contains the registry utility functions.
 | SerializationUtils | This class contains the serialization utility functions.
 | ServiceUtils..::.ServiceStart | This enum contains all the service start mode
 | ServiceUtils | This class contains the Window Service utility functions.
 | SqlClientUtils | This class contains the SqlServer utility functions.
 | StreamUtils | This class contains the stream utility functions.
 | StringUtils | This class contains the string utility functions.
 | SystemUtils | This class contains System utilities related to .Net or to the operating system.
 | WindowUtils | This class contains some Window Handle utility functions not related directly to WinForms.
 | WinFormsUtils | This class contains some Windows Form utility functions.
 | WMIUtils | This class contains some helper functions for WMI.
2008 Microsoft Corporation. All rights reserved.


ArrayUtils Class

ArrayUtils Class
Namespaces ► Devolutions.Utils ► ArrayUtils
This class contains the array utility functions.
Declaration Syntax
C# Visual Basic Visual C++
public static class ArrayUtils
Public NotInheritable Class ArrayUtils
public ref class ArrayUtils abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddAtBeginingToArray<(Of <(T>)>)(array<T>[]()[], T) | Insert an item at the begining of an array. A new array is returned.
 | AddRangeToArray<(Of <(T>)>)(array<T>[]()[], array<T>[]()[]) | Add a range of item in an array. A new array is returned.
 | AddToArray<(Of <(T>)>)(array<T>[]()[], T) | Add an item in an array. A new array is returned.
 | IsNullOrEmpty(Array) | Check if the array is null or empty.
 | Remove<(Of <(T>)>)(array<T>[]()[], T) | Remove an item from an array. A new array is created and no error is raised if the item does't exists.
 | SortStringArray(array<String>[]()[]) | Sort a string array (invariant culture)
Inheritance Hierarchy
Object
ArrayUtils

Assembly: Devolutions.Utils (Module: Devolutions.Utils)


AddAtBeginingToArray Method (aArray, aObject)

AddAtBeginingToArray<(Of <(T>)>) Method (aArray, aObject)
Namespaces ► Devolutions.Utils ► ArrayUtils ► AddAtBeginingToArray<(Of <(T>)>)(array<T>[]()[], T)
Insert an item at the begining of an array. A new array is returned.
Declaration Syntax
C# Visual Basic Visual C++
public static T[] AddAtBeginingToArray<T>(
    T[] aArray,
    T aObject
)

Public Shared Function AddAtBeginingToArray(Of T) ( _
    aArray As T(), _
    aObject As T _
) As T()
public:
generic<typename T>
static array<T>^ AddAtBeginingToArray(
    array<T>^ aArray,
    T aObject
)
Generic Template Parameters
T
Parameters
aArray (array< T >[]()[])
aObject (T)
Return Value


AddRangeToArray Method (aArray, aObjects)

AddRangeToArray<(Of <(T>)>) Method (aArray, aObjects)
Namespaces ► Devolutions.Utils ► ArrayUtils ► AddRangeToArray<(Of <(T>)>)(array<T>[]()[], array<T>[]()[])
Add a range of item in an array. A new array is returned.
Declaration Syntax
C# Visual Basic Visual C++
public static T[] AddRangeToArray<T>(
    T[] aArray,
    T[] aObjects
)

Public Shared Function AddRangeToArray(Of T) ( _
    aArray As T(), _
    aObjects As T() _
) As T()
public:
generic<typename T>
static array<T>^ AddRangeToArray(
    array<T>^ aArray,
    array<T>^ aObjects
)
Generic Template Parameters
T
Parameters
aArray (array< T >[]()[])
aObjects (array< T >[]()[])
Return Value


AddToArray Method (aArray, aObject)

AddToArray<(Of <(T>)>) Method (aArray, aObject)
Namespaces ► Devolutions.Utils ► ArrayUtils ► AddToArray<(Of <(T>)>)(array<T>[]()[], T)
Add an item in an array. A new array is returned.
Declaration Syntax
C# Visual Basic Visual C++
public static T[] AddToArray<T>(
    T[] aArray,
    T aObject
)

Public Shared Function AddToArray(Of T) ( _
    aArray As T(), _
    aObject As T _
) As T()
public:
generic<typename T>
static array<T>^ AddToArray(
    array<T>^ aArray,
    T aObject
)
Generic Template Parameters
T
Parameters
aArray (array< T >[]()[])
aObject (T)
Return Value


IsNullOrEmpty Method (aArray)

IsNullOrEmpty Method (aArray)
Namespaces ► Devolutions.Utils ► ArrayUtils ► IsNullOrEmpty(Array)
Check if the array is null or empty.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsNullOrEmpty(
    Array aArray
)
Public Shared Function IsNullOrEmpty ( _
    aArray As Array _
) As Boolean
public:
static bool IsNullOrEmpty(
    Array^ aArray
)
Parameters
aArray (Array)
Return Value


Remove Method (aArray, aObject)

Remove<(Of <(T>)>) Method (aArray, aObject)
Namespaces ► Devolutions.Utils ► ArrayUtils ► Remove<(Of <(T>)>)(array<T>[]()[], T)
Remove an item from an array. A new array is created and no error is raised if the item does't exists.
Declaration Syntax
C# Visual Basic Visual C++
public static T[] Remove<T>(
    T[] aArray,
    T aObject
)

Public Shared Function Remove(Of T) ( _
    aArray As T(), _
    aObject As T _
) As T()
public:
generic<typename T>
static array<T>^ Remove(
    array<T>^ aArray,
    T aObject
)
Generic Template Parameters
T
Array type
Parameters
aArray (array< T >[]()[])
The array
aObject (T)
The item to remove
Return Value


SortStringArray Method (aArray)

SortStringArray Method (aArray)
Namespaces ► Devolutions.Utils ► ArrayUtils ► SortStringArray(array<String>[]()[])
Sort a string array (invariant culture)
Declaration Syntax
C# Visual Basic Visual C++
public static string[] SortStringArray(
    string[] aArray
)
Public Shared Function SortStringArray ( _
    aArray As String() _
) As String()
public:
static array<String^>^ SortStringArray(
    array<String^>^ aArray
)
Parameters
aArray (array< String >[]()[])
Return Value


AspNetUtils Class

AspNetUtils Class
Namespaces ► Devolutions.Utils ► AspNetUtils
This class contains the ASP.NET utility functions.
Declaration Syntax
C# Visual Basic Visual C++
public static class AspNetUtils
Public NotInheritable Class AspNetUtils
public ref class AspNetUtils abstract sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FindControl<(Of <(T>)>)(Control, array<String>[]()[]) | Search a control in a control
 | IsAuthenticated | Indicate if the current user is authenticated
 | IsInternetConnected | Indicate if the current computer is connected to the internet
 | IsRunningInAspNet | Indicate if the current code is running in the ASP.NET process
 | QueryStringIsEqual(String, String) | Check if the query string equals a value
 | RestartWebSite()()() | Force a restart of the current ASP.NET process.
Inheritance Hierarchy
Object
AspNetUtils


FindControl Method (aParent, aNames)

FindControl<(Of <(T>)>) Method (aParent, aNames)
Namespaces ► Devolutions.Utils ► AspNetUtils ► FindControl<(Of <(T>)>)(Control, array<String>[]()[])
Search a control in a control
Declaration Syntax
C# Visual Basic Visual C++
public static T FindControl<T>(
    Control aParent,
    params string[] aNames
)
where T : Control

Public Shared Function FindControl(Of T As Control) ( _
    aParent As Control, _
    ParamArray aNames As String() _
) As T
public:
generic<typename T>
where T : Control
static T FindControl(
    Control^ aParent,
    ... array<String^>^ aNames
)
Generic Template Parameters
T
Parameters
aParent (Control)
aNames (array< String >[]()[])
Return Value


IsAuthenticated Property

IsAuthenticated Property
Namespaces ► Devolutions.Utils ► AspNetUtils ► IsAuthenticated
Indicate if the current user is authenticated
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsAuthenticated { get; }
Public Shared ReadOnly Property IsAuthenticated As Boolean
public:
static property bool IsAuthenticated {
    bool get ();
}


IsInternetConnected Property

IsInternetConnected Property
Namespaces ► Devolutions.Utils ► AspNetUtils ► IsInternetConnected
Indicate if the current computer is connected to the internet
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsInternetConnected { get; }
Public Shared ReadOnly Property IsInternetConnected As Boolean
public:
static property bool IsInternetConnected {
    bool get ();
}


IsRunningInAspNet Property

IsRunningInAspNet Property
Namespaces ► Devolutions.Utils ► AspNetUtils ► IsRunningInAspNet
Indicate if the current code is running in the ASP.NET process
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsRunningInAspNet { get; }
Public Shared ReadOnly Property IsRunningInAspNet As Boolean
public:
static property bool IsRunningInAspNet {
    bool get ();
}


QueryStringIsEqual Method (aName, aValue)

QueryStringIsEqual Method (aName, aValue)
Namespaces ► Devolutions.Utils ► AspNetUtils ► QueryStringIsEqual(String, String)
Check if the query string equals a value
Declaration Syntax
C# Visual Basic Visual C++
public static bool QueryStringIsEqual(
    string aName,
    string aValue
)
Public Shared Function QueryStringIsEqual ( _
    aName As String, _
    aValue As String _
) As Boolean
public:
static bool QueryStringIsEqual(
    String^ aName,
    String^ aValue
)
Parameters
aName (String)
aValue (String)
Return Value


RestartWebSite Method

RestartWebSite Method
Namespaces ► Devolutions.Utils ► AspNetUtils ► RestartWebSite()()()
Force a restart of the current ASP.NET process.
Declaration Syntax
C# Visual Basic Visual C++
public static void RestartWebSite()
Public Shared Sub RestartWebSite
public:
static void RestartWebSite()


BinarySerializationUtils Class

BinarySerializationUtils Class
Namespaces ► Devolutions.Utils ► BinarySerializationUtils
This class contains the serialization utility functions.
Declaration Syntax
C# Visual Basic Visual C++
public static class BinarySerializationUtils
Public NotInheritable Class BinarySerializationUtils
public ref class BinarySerializationUtils abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LoadObjectFromBytes<(Of <(T>)>)(array<Byte>[]()[], Boolean) | Read an object T from a byte array.
 | LoadObjectFromFile(String, Type) | Read an object from an binary file.
 | LoadObjectFromFile<(Of <(T>)>)(String) | Read an object T from a file
 | LoadObjectFromFile(String, Type, Boolean) | Read an object from an binary file.
 | LoadObjectFromFile<(Of <(T>)>)(String, Boolean) | Read an object T from an binary file.
 | LoadObjectFromString(String, Type, Boolean) | Read an object from a string.
 | SaveObjectToBytes(Object) | Save an object into an bytes array.
 | SaveObjectToFile(String, Object) | Save an object into an binary file.
Inheritance Hierarchy
Object
BinarySerializationUtils


LoadObjectFromBytes Method (aBytes, aCreateAnInstanceIfNotExists)

LoadObjectFromBytes<(Of <(T>)>) Method (aBytes, aCreateAnInstanceIfNotExists)
Namespaces ► Devolutions.Utils ► BinarySerializationUtils ► LoadObjectFromBytes<(Of <(T>)>)(array<Byte>[]()[], Boolean)
Read an object T from a byte array.
Declaration Syntax
C# Visual Basic Visual C++
public static T LoadObjectFromBytes<T>(
    byte[] aBytes,
    bool aCreateAnInstanceIfNotExists
)
where T : new()

Public Shared Function LoadObjectFromBytes(Of T As New) ( _
    aBytes As Byte(), _
    aCreateAnInstanceIfNotExists As Boolean _
) As T
public:
generic<typename T>
where T : gcnew()
static T LoadObjectFromBytes(
    array<unsigned char>^ aBytes,
    bool aCreateAnInstanceIfNotExists
)
Generic Template Parameters
T
Parameters
aBytes (array< Byte >[]()[])
aCreateAnInstanceIfNotExists (Boolean)
Return Value


LoadObjectFromFile Method

LoadObjectFromFile Method
Namespaces ► Devolutions.Utils ► BinarySerializationUtils ► LoadObjectFromFile()()()
Members
Icon | Member | Description
 | LoadObjectFromFile(String, Type) | Read an object from an binary file.
 | LoadObjectFromFile<(Of <(T>)>)(String) | Read an object T from a file
 | LoadObjectFromFile(String, Type, Boolean) | Read an object from an binary file.
 | LoadObjectFromFile<(Of <(T>)>)(String, Boolean) | Read an object T from an binary file.


LoadObjectFromFile Method (aFileName)

LoadObjectFromFile<(Of <(T>)>) Method (aFileName)
Namespaces ► Devolutions.Utils ► BinarySerializationUtils ► LoadObjectFromFile<(Of <(T>)>)(String)
Read an object T from a file
Declaration Syntax
C# Visual Basic Visual C++
public static T LoadObjectFromFile<T>(
    string aFileName
)

Public Shared Function LoadObjectFromFile(Of T) ( _
    aFileName As String _
) As T
public:
generic<typename T>
static T LoadObjectFromFile(
    String^ aFileName
)
Generic Template Parameters
T
Parameters
aFileName (String)
Return Value


LoadObjectFromFile Method (aFileName, aCreateAnInstanceIfNotExists)

LoadObjectFromFile<(Of <(T>)>) Method (aFileName, aCreateAnInstanceIfNotExists)
Namespaces ► Devolutions.Utils ► BinarySerializationUtils ► LoadObjectFromFile<(Of <(T>)>)(String, Boolean)
Read an object T from an binary file.
Declaration Syntax
C# Visual Basic Visual C++
public static T LoadObjectFromFile<T>(
    string aFileName,
    bool aCreateAnInstanceIfNotExists
)
where T : new()

Public Shared Function LoadObjectFromFile(Of T As New) ( _
    aFileName As String, _
    aCreateAnInstanceIfNotExists As Boolean _
) As T
public:
generic<typename T>
where T : gcnew()
static T LoadObjectFromFile(
    String^ aFileName,
    bool aCreateAnInstanceIfNotExists
)
Generic Template Parameters
T
Parameters
aFileName (String)
aCreateAnInstanceIfNotExists (Boolean)
Indicate if the method must create an empty instance if the file does not exists.
Return Value


LoadObjectFromFile Method (aFileName, aType)

LoadObjectFromFile Method (aFileName, aType)
Namespaces ► Devolutions.Utils ► BinarySerializationUtils ► LoadObjectFromFile(String, Type)
Read an object from an binary file.
Declaration Syntax
C# Visual Basic Visual C++
public static Object LoadObjectFromFile(
    string aFileName,
    Type aType
)
Public Shared Function LoadObjectFromFile ( _
    aFileName As String, _
    aType As Type _
) As Object
public:
static Object^ LoadObjectFromFile(
    String^ aFileName,
    Type^ aType
)
Parameters
aFileName (String)
aType (Type)
Return Value


LoadObjectFromFile Method (aFileName, aType, aCreateAnInstanceIfNotExists)

LoadObjectFromFile Method (aFileName, aType, aCreateAnInstanceIfNotExists)
Namespaces ► Devolutions.Utils ► BinarySerializationUtils ► LoadObjectFromFile(String, Type, Boolean)
Read an object from an binary file.
Declaration Syntax
C# Visual Basic Visual C++
public static Object LoadObjectFromFile(
    string aFileName,
    Type aType,
    bool aCreateAnInstanceIfNotExists
)
Public Shared Function LoadObjectFromFile ( _
    aFileName As String, _
    aType As Type, _
    aCreateAnInstanceIfNotExists As Boolean _
) As Object
public:
static Object^ LoadObjectFromFile(
    String^ aFileName,
    Type^ aType,
    bool aCreateAnInstanceIfNotExists
)
Parameters
aFileName (String)
aType (Type)
aCreateAnInstanceIfNotExists (Boolean)
Indicate if the method must create an empty instance if the file does not exists.
Return Value


LoadObjectFromString Method (aString, aType, aCreateAnInstanceIfNotExists)

LoadObjectFromString Method (aString, aType, aCreateAnInstanceIfNotExists)
Namespaces ► Devolutions.Utils ► BinarySerializationUtils ► LoadObjectFromString(String, Type, Boolean)
Read an object from a string.
Declaration Syntax
C# Visual Basic Visual C++
public static Object LoadObjectFromString(
    string aString,
    Type aType,
    bool aCreateAnInstanceIfNotExists
)
Public Shared Function LoadObjectFromString ( _
    aString As String, _
    aType As Type, _
    aCreateAnInstanceIfNotExists As Boolean _
) As Object
public:
static Object^ LoadObjectFromString(
    String^ aString,
    Type^ aType,
    bool aCreateAnInstanceIfNotExists
)
Parameters
aString (String)
aType (Type)
aCreateAnInstanceIfNotExists (Boolean)
Return Value


SaveObjectToBytes Method (aValue)

SaveObjectToBytes Method (aValue)
Namespaces ► Devolutions.Utils ► BinarySerializationUtils ► SaveObjectToBytes(Object)
Save an object into an bytes array.
Declaration Syntax
C# Visual Basic Visual C++
public static byte[] SaveObjectToBytes(
    Object aValue
)
Public Shared Function SaveObjectToBytes ( _
    aValue As Object _
) As Byte()
public:
static array<unsigned char>^ SaveObjectToBytes(
    Object^ aValue
)
Parameters
aValue (Object)


SaveObjectToFile Method (aFileName, aValue)

SaveObjectToFile Method (aFileName, aValue)
Namespaces ► Devolutions.Utils ► BinarySerializationUtils ► SaveObjectToFile(String, Object)
Save an object into an binary file.
Declaration Syntax
C# Visual Basic Visual C++
public static void SaveObjectToFile(
    string aFileName,
    Object aValue
)
Public Shared Sub SaveObjectToFile ( _
    aFileName As String, _
    aValue As Object _
)
public:
static void SaveObjectToFile(
    String^ aFileName,
    Object^ aValue
)
Parameters
aFileName (String)
aValue (Object)


DataSetUtils Class

DataSetUtils Class
Namespaces ► Devolutions.Utils ► DataSetUtils
This class contains dataset utility functions.
Declaration Syntax
C# Visual Basic Visual C++
public static class DataSetUtils
Public NotInheritable Class DataSetUtils
public ref class DataSetUtils abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddOrImportRow(DataTable, DataRow) | Add a row to a datatable. If the row is owned by an other table, the row is imported in the destination.
 | ClearDataTableValues(DataSet, String) | Clear the table values and accept the changes for this table.
 | DataSourceToDataView(Object) | Return the DataView from different data source.
 | DataSourceToDataView(Object, String) | Return the DataView from different data source.
 | DataTableHasChanges(DataSet, String) | Check if the Datable has changes
 | FillDataRowFromObject(Type, DataRow, Object) | Fill all the column values to a data row from with the public properties of an object. String, Double Bool and DateTime types are supported.
 | FillMetaDataRowFromObject(Type, DataTable) | Create a table with the public properties of an object.
 | FindDataRow(DataTable, String, String) | Optimized find datarow.
 | FindDataRow(DataView, String, String) | Optimized find datarow.
 | FindIndexOfDataRowInDataView(DataView, DataRow) | Return the index of a data row in a DataView.
 | GetChangedRows(DataSet, String) | Returned the deleted, modified or inserted row for a table.
 | GetRows(DataSet, String, DataViewRowState) | Returned the rows matching a specific row state in a table.
 | IsNullOrDBNull(Object) | Return true if the parameter is null or DBNullValue
 | IsNullOrDBNullOrEmpty(Object) | Return true if the parameter is null or DBNullValue or String.Empty
 | ReadValueAsString(DataRow, String) | Read a datarow value as a string.
 | ReadValueAsString(DataRow, String, Boolean) | Read a datarow value as a string.
 | SetDataRowValue(DataRow, String, Object) | Set a datarow if the value is different of the current one.
Inheritance Hierarchy
Object
DataSetUtils


AddOrImportRow Method (aDestinationDataTable, aDataRow)

AddOrImportRow Method (aDestinationDataTable, aDataRow)
Namespaces ► Devolutions.Utils ► DataSetUtils ► AddOrImportRow(DataTable, DataRow)
Add a row to a datatable. If the row is owned by an other table, the row is imported in the destination.
Declaration Syntax
C# Visual Basic Visual C++
public static void AddOrImportRow(
    DataTable aDestinationDataTable,
    DataRow aDataRow
)
Public Shared Sub AddOrImportRow ( _
    aDestinationDataTable As DataTable, _
    aDataRow As DataRow _
)
public:
static void AddOrImportRow(
    DataTable^ aDestinationDataTable,
    DataRow^ aDataRow
)
Parameters
aDestinationDataTable (DataTable)
aDataRow (DataRow)


ClearDataTableValues Method (aDataSet, aTableName)

ClearDataTableValues Method (aDataSet, aTableName)
Namespaces ► Devolutions.Utils ► DataSetUtils ► ClearDataTableValues(DataSet, String)
Clear the table values and accept the changes for this table.
Declaration Syntax
C# Visual Basic Visual C++
public static void ClearDataTableValues(
    DataSet aDataSet,
    string aTableName
)
Public Shared Sub ClearDataTableValues ( _
    aDataSet As DataSet, _
    aTableName As String _
)
public:
static void ClearDataTableValues(
    DataSet^ aDataSet,
    String^ aTableName
)
Parameters
aDataSet (DataSet)
aTableName (String)


DataSourceToDataView Method

DataSourceToDataView Method
Namespaces ► Devolutions.Utils ► DataSetUtils ► DataSourceToDataView()()()
Members
Icon | Member | Description
 | DataSourceToDataView(Object) | Return the DataView from different data source.
 | DataSourceToDataView(Object, String) | Return the DataView from different data source.


DataSourceToDataView Method (aDataSource)

DataSourceToDataView Method (aDataSource)
Namespaces ► Devolutions.Utils ► DataSetUtils ► DataSourceToDataView(Object)
Return the DataView from different data source.
Declaration Syntax
C# Visual Basic Visual C++
public static DataView DataSourceToDataView(
    Object aDataSource
)
Public Shared Function DataSourceToDataView ( _
    aDataSource As Object _
) As DataView
public:
static DataView^ DataSourceToDataView(
    Object^ aDataSource
)
Parameters
aDataSource (Object)
Return Value


DataSourceToDataView Method (aDataSource, aTableName)

DataSourceToDataView Method (aDataSource, aTableName)
Namespaces ► Devolutions.Utils ► DataSetUtils ► DataSourceToDataView(Object, String)
Return the DataView from different data source.
Declaration Syntax
C# Visual Basic Visual C++
public static DataView DataSourceToDataView(
    Object aDataSource,
    string aTableName
)
Public Shared Function DataSourceToDataView ( _
    aDataSource As Object, _
    aTableName As String _
) As DataView
public:
static DataView^ DataSourceToDataView(
    Object^ aDataSource,
    String^ aTableName
)
Parameters
aDataSource (Object)
aTableName (String)
Return Value


DataTableHasChanges Method (aDataSet, aTableName)

DataTableHasChanges Method (aDataSet, aTableName)
Namespaces ► Devolutions.Utils ► DataSetUtils ► DataTableHasChanges(DataSet, String)
Check if the Datable has changes
Declaration Syntax
C# Visual Basic Visual C++
public static bool DataTableHasChanges(
    DataSet aDataSet,
    string aTableName
)
Public Shared Function DataTableHasChanges ( _
    aDataSet As DataSet, _
    aTableName As String _
) As Boolean
public:
static bool DataTableHasChanges(
    DataSet^ aDataSet,
    String^ aTableName
)
Parameters
aDataSet (DataSet)
aTableName (String)
Return Value


FillDataRowFromObject Method (aType, aDataRow, aObject)

FillDataRowFromObject Method (aType, aDataRow, aObject)
Namespaces ► Devolutions.Utils ► DataSetUtils ► FillDataRowFromObject(Type, DataRow, Object)
Fill all the column values to a data row from with the public properties of an object. String, Double Bool and DateTime types are supported.
Declaration Syntax
C# Visual Basic Visual C++
public static void FillDataRowFromObject(
    Type aType,
    DataRow aDataRow,
    Object aObject
)
Public Shared Sub FillDataRowFromObject ( _
    aType As Type, _
    aDataRow As DataRow, _
    aObject As Object _
)
public:
static void FillDataRowFromObject(
    Type^ aType,
    DataRow^ aDataRow,
    Object^ aObject
)
Parameters
aType (Type)
aDataRow (DataRow)
aObject (Object)


FillMetaDataRowFromObject Method (aType, aDataTable)

FillMetaDataRowFromObject Method (aType, aDataTable)
Namespaces ► Devolutions.Utils ► DataSetUtils ► FillMetaDataRowFromObject(Type, DataTable)
Create a table with the public properties of an object.
Declaration Syntax
C# Visual Basic Visual C++
public static DataTable FillMetaDataRowFromObject(
    Type aType,
    DataTable aDataTable
)
Public Shared Function FillMetaDataRowFromObject ( _
    aType As Type, _
    aDataTable As DataTable _
) As DataTable
public:
static DataTable^ FillMetaDataRowFromObject(
    Type^ aType,
    DataTable^ aDataTable
)
Parameters
aType (Type)
aDataTable (DataTable)
Return Value


FindDataRow Method

FindDataRow Method
Namespaces ► Devolutions.Utils ► DataSetUtils ► FindDataRow()()()
Members
Icon | Member | Description
 | FindDataRow(DataTable, String, String) | Optimized find datarow.
 | FindDataRow(DataView, String, String) | Optimized find datarow.


FindDataRow Method (aDataTable, aSearchFieldName, aSearchValue)

FindDataRow Method (aDataTable, aSearchFieldName, aSearchValue)
Namespaces ► Devolutions.Utils ► DataSetUtils ► FindDataRow(DataTable, String, String)
Optimized find datarow.
Declaration Syntax
C# Visual Basic Visual C++
public static DataRow FindDataRow(
    DataTable aDataTable,
    string aSearchFieldName,
    string aSearchValue
)
Public Shared Function FindDataRow ( _
    aDataTable As DataTable, _
    aSearchFieldName As String, _
    aSearchValue As String _
) As DataRow
public:
static DataRow^ FindDataRow(
    DataTable^ aDataTable,
    String^ aSearchFieldName,
    String^ aSearchValue
)
Parameters
aDataTable (DataTable)
aSearchFieldName (String)
aSearchValue (String)
Return Value


FindDataRow Method (aDataView, aSearchFieldName, aSearchValue)

FindDataRow Method (aDataView, aSearchFieldName, aSearchValue)
Namespaces ► Devolutions.Utils ► DataSetUtils ► FindDataRow(DataView, String, String)
Optimized find datarow.
Declaration Syntax
C# Visual Basic Visual C++
public static DataRow FindDataRow(
    DataView aDataView,
    string aSearchFieldName,
    string aSearchValue
)
Public Shared Function FindDataRow ( _
    aDataView As DataView, _
    aSearchFieldName As String, _
    aSearchValue As String _
) As DataRow
public:
static DataRow^ FindDataRow(
    DataView^ aDataView,
    String^ aSearchFieldName,
    String^ aSearchValue
)
Parameters
aDataView (DataView)
aSearchFieldName (String)
aSearchValue (String)
Return Value


FindIndexOfDataRowInDataView Method (aDataView, aDataRow)

FindIndexOfDataRowInDataView Method (aDataView, aDataRow)
Namespaces ► Devolutions.Utils ► DataSetUtils ► FindIndexOfDataRowInDataView(DataView, DataRow)
Return the index of a data row in a DataView.
Declaration Syntax
C# Visual Basic Visual C++
public static int FindIndexOfDataRowInDataView(
    DataView aDataView,
    DataRow aDataRow
)
Public Shared Function FindIndexOfDataRowInDataView ( _
    aDataView As DataView, _
    aDataRow As DataRow _
) As Integer
public:
static int FindIndexOfDataRowInDataView(
    DataView^ aDataView,
    DataRow^ aDataRow
)
Parameters
aDataView (DataView)
aDataRow (DataRow)
Return Value


GetChangedRows Method (aDataSet, aTableName)

GetChangedRows Method (aDataSet, aTableName)
Namespaces ► Devolutions.Utils ► DataSetUtils ► GetChangedRows(DataSet, String)
Returned the deleted, modified or inserted row for a table.
Declaration Syntax
C# Visual Basic Visual C++
public static DataRow[] GetChangedRows(
    DataSet aDataSet,
    string aTableName
)
Public Shared Function GetChangedRows ( _
    aDataSet As DataSet, _
    aTableName As String _
) As DataRow()
public:
static array<DataRow^>^ GetChangedRows(
    DataSet^ aDataSet,
    String^ aTableName
)
Parameters
aDataSet (DataSet)
aTableName (String)
Return Value


GetRows Method (aDataSet, aTableName, aDataViewRowState)

GetRows Method (aDataSet, aTableName, aDataViewRowState)
Namespaces ► Devolutions.Utils ► DataSetUtils ► GetRows(DataSet, String, DataViewRowState)
Returned the rows matching a specific row state in a table.
Declaration Syntax
C# Visual Basic Visual C++
public static DataRow[] GetRows(
    DataSet aDataSet,
    string aTableName,
    DataViewRowState aDataViewRowState
)
Public Shared Function GetRows ( _
    aDataSet As DataSet, _
    aTableName As String, _
    aDataViewRowState As DataViewRowState _
) As DataRow()
public:
static array<DataRow^>^ GetRows(
    DataSet^ aDataSet,
    String^ aTableName,
    DataViewRowState aDataViewRowState
)
Parameters
aDataSet (DataSet)
aTableName (String)
aDataViewRowState (DataViewRowState)
Return Value


IsNullOrDBNull Method (aObject)

IsNullOrDBNull Method (aObject)
Namespaces ► Devolutions.Utils ► DataSetUtils ► IsNullOrDBNull(Object)
Return true if the parameter is null or DBNullValue
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsNullOrDBNull(
    Object aObject
)
Public Shared Function IsNullOrDBNull ( _
    aObject As Object _
) As Boolean
public:
static bool IsNullOrDBNull(
    Object^ aObject
)
Parameters
aObject (Object)
Return Value


IsNullOrDBNullOrEmpty Method (aObject)

IsNullOrDBNullOrEmpty Method (aObject)
Namespaces ► Devolutions.Utils ► DataSetUtils ► IsNullOrDBNullOrEmpty(Object)
Return true if the parameter is null or DBNullValue or String.Empty
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsNullOrDBNullOrEmpty(
    Object aObject
)
Public Shared Function IsNullOrDBNullOrEmpty ( _
    aObject As Object _
) As Boolean
public:
static bool IsNullOrDBNullOrEmpty(
    Object^ aObject
)
Parameters
aObject (Object)
Return Value


ReadValueAsString Method

ReadValueAsString Method
Namespaces ► Devolutions.Utils ► DataSetUtils ► ReadValueAsString()()()
Members
Icon | Member | Description
 | ReadValueAsString(DataRow, String) | Read a datarow value as a string.
 | ReadValueAsString(DataRow, String, Boolean) | Read a datarow value as a string.


ReadValueAsString Method (aDataRow, aFieldName)

ReadValueAsString Method (aDataRow, aFieldName)
Namespaces ► Devolutions.Utils ► DataSetUtils ► ReadValueAsString(DataRow, String)
Read a datarow value as a string.
Declaration Syntax
C# Visual Basic Visual C++
public static string ReadValueAsString(
    DataRow aDataRow,
    string aFieldName
)
Public Shared Function ReadValueAsString ( _
    aDataRow As DataRow, _
    aFieldName As String _
) As String
public:
static String^ ReadValueAsString(
    DataRow^ aDataRow,
    String^ aFieldName
)
Parameters
aDataRow (DataRow)
aFieldName (String)
Return Value


ReadValueAsString Method (aDataRow, aFieldName, aReturnNullOnEmptyString)

ReadValueAsString Method (aDataRow, aFieldName, aReturnNullOnEmptyString)
Namespaces ► Devolutions.Utils ► DataSetUtils ► ReadValueAsString(DataRow, String, Boolean)
Read a datarow value as a string.
Declaration Syntax
C# Visual Basic Visual C++
public static string ReadValueAsString(
    DataRow aDataRow,
    string aFieldName,
    bool aReturnNullOnEmptyString
)
Public Shared Function ReadValueAsString ( _
    aDataRow As DataRow, _
    aFieldName As String, _
    aReturnNullOnEmptyString As Boolean _
) As String
public:
static String^ ReadValueAsString(
    DataRow^ aDataRow,
    String^ aFieldName,
    bool aReturnNullOnEmptyString
)
Parameters
aDataRow (DataRow)
aFieldName (String)
aReturnNullOnEmptyString (Boolean)
Return Value


SetDataRowValue Method (aDataRow, aColumnName, aValue)

SetDataRowValue Method (aDataRow, aColumnName, aValue)
Namespaces ► Devolutions.Utils ► DataSetUtils ► SetDataRowValue(DataRow, String, Object)
Set a datarow if the value is different of the current one.
Declaration Syntax
C# Visual Basic Visual C++
public static void SetDataRowValue(
    DataRow aDataRow,
    string aColumnName,
    Object aValue
)
Public Shared Sub SetDataRowValue ( _
    aDataRow As DataRow, _
    aColumnName As String, _
    aValue As Object _
)
public:
static void SetDataRowValue(
    DataRow^ aDataRow,
    String^ aColumnName,
    Object^ aValue
)
Parameters
aDataRow (DataRow)
aColumnName (String)
aValue (Object)


DateUtils Class

DateUtils Class
Namespaces ► Devolutions.Utils ► DateUtils
This class contains the date utility functions.
Declaration Syntax
C# Visual Basic Visual C++
public static class DateUtils
Public NotInheritable Class DateUtils
public ref class DateUtils abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetEndOfDay(DateTime) | Return the end of a day from a date
 | GetStartOfDay(DateTime) | Return the begining of a day from a date
 | IsBetween(DateTime, DateTime, DateTime) | Check if a date is between two dates
 | IsBetween(DateTime, DateTime, DateTime, Boolean) | Check if a date is between two dates
 | UseTwentyFourHoursFormat()()() | Check if the Current Culture uses a 24 hours format
 | UseTwentyFourHoursFormat(CultureInfo) | Check if the Culture uses a 24 hours format
Inheritance Hierarchy
Object
DateUtils


GetEndOfDay Method (aDateTime)

GetEndOfDay Method (aDateTime)
Namespaces ► Devolutions.Utils ► DateUtils ► GetEndOfDay(DateTime)
Return the end of a day from a date
Declaration Syntax
C# Visual Basic Visual C++
public static DateTime GetEndOfDay(
    DateTime aDateTime
)
Public Shared Function GetEndOfDay ( _
    aDateTime As DateTime _
) As DateTime
public:
static DateTime GetEndOfDay(
    DateTime aDateTime
)
Parameters
aDateTime (DateTime)
Return Value


GetStartOfDay Method (aDateTime)

GetStartOfDay Method (aDateTime)
Namespaces ► Devolutions.Utils ► DateUtils ► GetStartOfDay(DateTime)
Return the begining of a day from a date
Declaration Syntax
C# Visual Basic Visual C++
public static DateTime GetStartOfDay(
    DateTime aDateTime
)
Public Shared Function GetStartOfDay ( _
    aDateTime As DateTime _
) As DateTime
public:
static DateTime GetStartOfDay(
    DateTime aDateTime
)
Parameters
aDateTime (DateTime)
Return Value


IsBetween Method

IsBetween Method
Namespaces ► Devolutions.Utils ► DateUtils ► IsBetween()()()
Members
Icon | Member | Description
 | IsBetween(DateTime, DateTime, DateTime) | Check if a date is between two dates
 | IsBetween(DateTime, DateTime, DateTime, Boolean) | Check if a date is between two dates


IsBetween Method (aMinInterval, aMaxInterval, aValue)

IsBetween Method (aMinInterval, aMaxInterval, aValue)
Namespaces ► Devolutions.Utils ► DateUtils ► IsBetween(DateTime, DateTime, DateTime)
Check if a date is between two dates
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsBetween(
    DateTime aMinInterval,
    DateTime aMaxInterval,
    DateTime aValue
)
Public Shared Function IsBetween ( _
    aMinInterval As DateTime, _
    aMaxInterval As DateTime, _
    aValue As DateTime _
) As Boolean
public:
static bool IsBetween(
    DateTime aMinInterval,
    DateTime aMaxInterval,
    DateTime aValue
)
Parameters
aMinInterval (DateTime)
aMaxInterval (DateTime)
aValue (DateTime)
Return Value


IsBetween Method (aMinInterval, aMaxInterval, aValue, aIncludeMinMax)

IsBetween Method (aMinInterval, aMaxInterval, aValue, aIncludeMinMax)
Namespaces ► Devolutions.Utils ► DateUtils ► IsBetween(DateTime, DateTime, DateTime, Boolean)
Check if a date is between two dates
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsBetween(
    DateTime aMinInterval,
    DateTime aMaxInterval,
    DateTime aValue,
    bool aIncludeMinMax
)
Public Shared Function IsBetween ( _
    aMinInterval As DateTime, _
    aMaxInterval As DateTime, _
    aValue As DateTime, _
    aIncludeMinMax As Boolean _
) As Boolean
public:
static bool IsBetween(
    DateTime aMinInterval,
    DateTime aMaxInterval,
    DateTime aValue,
    bool aIncludeMinMax
)
Parameters
aMinInterval (DateTime)
aMaxInterval (DateTime)
aValue (DateTime)
aIncludeMinMax (Boolean)
Return Value


UseTwentyFourHoursFormat Method

UseTwentyFourHoursFormat Method
Namespaces ► Devolutions.Utils ► DateUtils ► UseTwentyFourHoursFormat()()()
Members
Icon | Member | Description
 | UseTwentyFourHoursFormat()()() | Check if the Current Culture uses a 24 hours format
 | UseTwentyFourHoursFormat(CultureInfo) | Check if the Culture uses a 24 hours format


UseTwentyFourHoursFormat Method

UseTwentyFourHoursFormat Method
Namespaces ► Devolutions.Utils ► DateUtils ► UseTwentyFourHoursFormat()()()
Check if the Current Culture uses a 24 hours format
Declaration Syntax
C# Visual Basic Visual C++
public static bool UseTwentyFourHoursFormat()
Public Shared Function UseTwentyFourHoursFormat As Boolean
public:
static bool UseTwentyFourHoursFormat()
Return Value


UseTwentyFourHoursFormat Method (aCultureInfo)

UseTwentyFourHoursFormat Method (aCultureInfo)
Namespaces ► Devolutions.Utils ► DateUtils ► UseTwentyFourHoursFormat(CultureInfo)
Check if the Culture uses a 24 hours format
Declaration Syntax
C# Visual Basic Visual C++
public static bool UseTwentyFourHoursFormat(
    CultureInfo aCultureInfo
)
Public Shared Function UseTwentyFourHoursFormat ( _
    aCultureInfo As CultureInfo _
) As Boolean
public:
static bool UseTwentyFourHoursFormat(
    CultureInfo^ aCultureInfo
)
Parameters
aCultureInfo (CultureInfo)
Return Value


FileUtils Class

FileUtils Class
Namespaces ► Devolutions.Utils ► FileUtils
This class contains the file utility functions.
Declaration Syntax
C# Visual Basic Visual C++
public static class FileUtils
Public NotInheritable Class FileUtils
public ref class FileUtils abstract sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ApplicationDirectory | Return the Application directory name or the virtual directory path
 | CopyFiles(String, String) | Copy all the files and sub directories in a new folder. Read only file will be replaced with the new one.
 | CreateDirectory(String) | Create a directory if it does not exist.
 | DeleteDirectory(String, Boolean, Boolean, Boolean, Boolean, array<String>[]()[], array<String>[]()[]) | Delete a directory and all it's sub drectories if aRecursive and aDeleteSubDirectories aRecursive true. If aRecursive is true but aDeleteSubDirectories, only the file in the subdirectories are deleted.
 | FileIsHidden(String) | Return true if the file is hidden
 | FileIsReadOnly(String) | Return true if the file is read only
 | FileIsValid(String) | Return true if the file exists and it's size is greater than 0.
 | GetAssemblyVersion(Assembly) | Return the file version from an assembly
 | GetDirectorySize(String, Boolean) | Return the size of a directory
 | GetFileVersion(String) | Return the file version for a specific file name.
 | GetRelativePath(String) | Return the relative path from the current directory.
 | GetRelativePath(String, String) | Return a relative path from a root path.
 | GetShortPath(String) | Return the short path form for a specific path
 | IncludeTraillingSlash(String) | Add a backslash to a path if it's does not end with.
 | SetFileReadOnly(String, Boolean) | Change the readonly attribut to a file.
 | ValidateFileName(String) | Return true if the name is valid (the name, not the file)
Inheritance Hierarchy
Object
FileUtils


ApplicationDirectory Property

ApplicationDirectory Property
Namespaces ► Devolutions.Utils ► FileUtils ► ApplicationDirectory
Return the Application directory name or the virtual directory path
Declaration Syntax
C# Visual Basic Visual C++
public static string ApplicationDirectory { get; }
Public Shared ReadOnly Property ApplicationDirectory As String
public:
static property String^ ApplicationDirectory {
    String^ get ();
}


CopyFiles Method (aSourceFileOrDirectoryPath, aDestinationFileOrDirectoryPath)

CopyFiles Method (aSourceFileOrDirectoryPath, aDestinationFileOrDirectoryPath)
Namespaces ► Devolutions.Utils ► FileUtils ► CopyFiles(String, String)
Copy all the files and sub directories in a new folder. Read only file will be replaced with the new one.
Declaration Syntax
C# Visual Basic Visual C++
public static bool CopyFiles(
    string aSourceFileOrDirectoryPath,
    string aDestinationFileOrDirectoryPath
)
Public Shared Function CopyFiles ( _
    aSourceFileOrDirectoryPath As String, _
    aDestinationFileOrDirectoryPath As String _
) As Boolean
public:
static bool CopyFiles(
    String^ aSourceFileOrDirectoryPath,
    String^ aDestinationFileOrDirectoryPath
)
Parameters
aSourceFileOrDirectoryPath (String)
aDestinationFileOrDirectoryPath (String)
Return Value


CreateDirectory Method (aPath)

CreateDirectory Method (aPath)
Namespaces ► Devolutions.Utils ► FileUtils ► CreateDirectory(String)
Create a directory if it does not exist.
Declaration Syntax
C# Visual Basic Visual C++
public static void CreateDirectory(
    string aPath
)
Public Shared Sub CreateDirectory ( _
    aPath As String _
)
public:
static void CreateDirectory(
    String^ aPath
)
Parameters
aPath (String)


DeleteDirectory Method (aPath, aDeleteStartingDirectory, aRecursive, aDeleteSubDirectories, aThrowError, aExcludingFiles, aIncludingFiles)

DeleteDirectory Method (aPath, aDeleteStartingDirectory, aRecursive, aDeleteSubDirectories, aThrowError, aExcludingFiles, aIncludingFiles)
Namespaces ► Devolutions.Utils ► FileUtils ► DeleteDirectory(String, Boolean, Boolean, Boolean, Boolean, array<String>[]()[], array<String>[]()[])
Delete a directory and all it's sub drectories if aRecursive and aDeleteSubDirectories aRecursive true. If aRecursive is true but aDeleteSubDirectories, only the file in the subdirectories are deleted.
Declaration Syntax
C# Visual Basic Visual C++
public static bool DeleteDirectory(
    string aPath,
    bool aDeleteStartingDirectory,
    bool aRecursive,
    bool aDeleteSubDirectories,
    bool aThrowError,
    string[] aExcludingFiles,
    string[] aIncludingFiles
)
Public Shared Function DeleteDirectory ( _
    aPath As String, _
    aDeleteStartingDirectory As Boolean, _
    aRecursive As Boolean, _
    aDeleteSubDirectories As Boolean, _
    aThrowError As Boolean, _
    aExcludingFiles As String(), _
    aIncludingFiles As String() _
) As Boolean
public:
static bool DeleteDirectory(
    String^ aPath,
    bool aDeleteStartingDirectory,
    bool aRecursive,
    bool aDeleteSubDirectories,
    bool aThrowError,
    array<String^>^ aExcludingFiles,
    array<String^>^ aIncludingFiles
)
Parameters
aPath (String)
Path to delete
aDeleteStartingDirectory (Boolean)
Indicate if the starting directory must be deleted.
aRecursive (Boolean)
Indicate if the delete must be recursive or not.
aDeleteSubDirectories (Boolean)
Indicate if the the folder in the subdirectory must be deleted.
aThrowError (Boolean)
If aThrowError is false, error will not be raised and the process will continue.
aExcludingFiles (array< String >[]()[])
Mask of excluded files.
aIncludingFiles (array< String >[]()[])
Mask of included files.
Return Value


FileIsHidden Method (aFileName)

FileIsHidden Method (aFileName)
Namespaces ► Devolutions.Utils ► FileUtils ► FileIsHidden(String)
Return true if the file is hidden
Declaration Syntax
C# Visual Basic Visual C++
public static bool FileIsHidden(
    string aFileName
)
Public Shared Function FileIsHidden ( _
    aFileName As String _
) As Boolean
public:
static bool FileIsHidden(
    String^ aFileName
)
Parameters
aFileName (String)
Return Value


FileIsReadOnly Method (aFileName)

FileIsReadOnly Method (aFileName)
Namespaces ► Devolutions.Utils ► FileUtils ► FileIsReadOnly(String)
Return true if the file is read only
Declaration Syntax
C# Visual Basic Visual C++
public static bool FileIsReadOnly(
    string aFileName
)
Public Shared Function FileIsReadOnly ( _
    aFileName As String _
) As Boolean
public:
static bool FileIsReadOnly(
    String^ aFileName
)
Parameters
aFileName (String)
Return Value


FileIsValid Method (aFileName)

FileIsValid Method (aFileName)
Namespaces ► Devolutions.Utils ► FileUtils ► FileIsValid(String)
Return true if the file exists and it's size is greater than 0.
Declaration Syntax
C# Visual Basic Visual C++
public static bool FileIsValid(
    string aFileName
)
Public Shared Function FileIsValid ( _
    aFileName As String _
) As Boolean
public:
static bool FileIsValid(
    String^ aFileName
)
Parameters
aFileName (String)
Return Value


GetAssemblyVersion Method (aAssembly)

GetAssemblyVersion Method (aAssembly)
Namespaces ► Devolutions.Utils ► FileUtils ► GetAssemblyVersion(Assembly)
Return the file version from an assembly
Declaration Syntax
C# Visual Basic Visual C++
public static string GetAssemblyVersion(
    Assembly aAssembly
)
Public Shared Function GetAssemblyVersion ( _
    aAssembly As Assembly _
) As String
public:
static String^ GetAssemblyVersion(
    Assembly^ aAssembly
)
Parameters
aAssembly (Assembly)
Return Value


GetDirectorySize Method (aDirectory, aIncludeSubDirectories)

GetDirectorySize Method (aDirectory, aIncludeSubDirectories)
Namespaces ► Devolutions.Utils ► FileUtils ► GetDirectorySize(String, Boolean)
Return the size of a directory
Declaration Syntax
C# Visual Basic Visual C++
public static long GetDirectorySize(
    string aDirectory,
    bool aIncludeSubDirectories
)
Public Shared Function GetDirectorySize ( _
    aDirectory As String, _
    aIncludeSubDirectories As Boolean _
) As Long
public:
static long long GetDirectorySize(
    String^ aDirectory,
    bool aIncludeSubDirectories
)
Parameters
aDirectory (String)
aIncludeSubDirectories (Boolean)
Return Value


GetFileVersion Method (aFileName)

GetFileVersion Method (aFileName)
Namespaces ► Devolutions.Utils ► FileUtils ► GetFileVersion(String)
Return the file version for a specific file name.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetFileVersion(
    string aFileName
)
Public Shared Function GetFileVersion ( _
    aFileName As String _
) As String
public:
static String^ GetFileVersion(
    String^ aFileName
)
Parameters
aFileName (String)
Return Value


GetRelativePath Method

GetRelativePath Method
Namespaces ► Devolutions.Utils ► FileUtils ► GetRelativePath()()()
Members
Icon | Member | Description
 | GetRelativePath(String) | Return the relative path from the current directory.
 | GetRelativePath(String, String) | Return a relative path from a root path.


GetRelativePath Method (aFilePath)

GetRelativePath Method (aFilePath)
Namespaces ► Devolutions.Utils ► FileUtils ► GetRelativePath(String)
Return the relative path from the current directory.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetRelativePath(
    string aFilePath
)
Public Shared Function GetRelativePath ( _
    aFilePath As String _
) As String
public:
static String^ GetRelativePath(
    String^ aFilePath
)
Parameters
aFilePath (String)
Return Value


GetRelativePath Method (aRootPath, aFilePath)

GetRelativePath Method (aRootPath, aFilePath)
Namespaces ► Devolutions.Utils ► FileUtils ► GetRelativePath(String, String)
Return a relative path from a root path.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetRelativePath(
    string aRootPath,
    string aFilePath
)
Public Shared Function GetRelativePath ( _
    aRootPath As String, _
    aFilePath As String _
) As String
public:
static String^ GetRelativePath(
    String^ aRootPath,
    String^ aFilePath
)
Parameters
aRootPath (String)
aFilePath (String)
Return Value


GetShortPath Method (aPath)

GetShortPath Method (aPath)
Namespaces ► Devolutions.Utils ► FileUtils ► GetShortPath(String)
Return the short path form for a specific path
Declaration Syntax
C# Visual Basic Visual C++
public static string GetShortPath(
    string aPath
)
Public Shared Function GetShortPath ( _
    aPath As String _
) As String
public:
static String^ GetShortPath(
    String^ aPath
)
Parameters
aPath (String)
The long name path
Return Value
A short name path string


IncludeTraillingSlash Method (aPath)

IncludeTraillingSlash Method (aPath)
Namespaces ► Devolutions.Utils ► FileUtils ► IncludeTraillingSlash(String)
Add a backslash to a path if it's does not end with.
Declaration Syntax
C# Visual Basic Visual C++
public static string IncludeTraillingSlash(
    string aPath
)
Public Shared Function IncludeTraillingSlash ( _
    aPath As String _
) As String
public:
static String^ IncludeTraillingSlash(
    String^ aPath
)
Parameters
aPath (String)
Return Value


SetFileReadOnly Method (aFileName, aValue)

SetFileReadOnly Method (aFileName, aValue)
Namespaces ► Devolutions.Utils ► FileUtils ► SetFileReadOnly(String, Boolean)
Change the readonly attribut to a file.
Declaration Syntax
C# Visual Basic Visual C++
public static void SetFileReadOnly(
    string aFileName,
    bool aValue
)
Public Shared Sub SetFileReadOnly ( _
    aFileName As String, _
    aValue As Boolean _
)
public:
static void SetFileReadOnly(
    String^ aFileName,
    bool aValue
)
Parameters
aFileName (String)
aValue (Boolean)


ValidateFileName Method (aName)

ValidateFileName Method (aName)
Namespaces ► Devolutions.Utils ► FileUtils ► ValidateFileName(String)
Return true if the name is valid (the name, not the file)
Declaration Syntax
C# Visual Basic Visual C++
public static bool ValidateFileName(
    string aName
)
Public Shared Function ValidateFileName ( _
    aName As String _
) As Boolean
public:
static bool ValidateFileName(
    String^ aName
)
Parameters
aName (String)
Return Value


IISUtils Class

IISUtils Class
Namespaces ► Devolutions.Utils ► IISUtils
This class contains the IIS utility functions.
Declaration Syntax
C# Visual Basic Visual C++
public static class IISUtils
Public NotInheritable Class IISUtils
public ref class IISUtils abstract sealed
Members
All Members | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ASP_NET_WP_PROCESS | Windows XP, Windows 2000 ASP.NET process name
 | CreateVirtualDirectory(String, String, String) | Create a new virtual directory.
 | DEFAULT_IIS_ROOT_FOLDER | Default IIS Root
 | GetVirtualDirectory(String, String) | Return the Directory Information for a virtual directory.
 | GetVirtualDirectoryList()()() | Return the list of all the installed local Virtual Directory
 | IIS_SERVICE_NAME | IIS Service name
 | IISVersion | Return the installed IIS version or null if not installed
 | IsIISServiceRunning | Indicate if IIS is running.
 | OpenIISManager()()() | Open the IIS Manager property window.
 | ReadAllProperties(String, String) | Return all the informations for a virtual directory.
 | SetDirectoryBrowsing(String, Boolean) | Change the directory browsing value for a virtual directory.
 | SetVirtualDirectoryProperty(DirectoryEntry, String, Object) | Change a virtual directory property.
 | StartIIS()()() | Start the IIS Service.
 | StopIIS()()() | Stop the IIS Service.
 | SwitchVirtualDirectoryToADirectory(String) | Set a virtual directory to a folder.
 | SwitchVirtualDirectoryToADirectory(String, String) | Set a virtual directory to a folder.
 | SwitchVirtualDirectoryToARedirection(String, String) | Set a redirection to a virtual directory
 | SwitchVirtualDirectoryToARedirection(String, String, String) | Set a redirection to a virtual directory
 | TerminateAspWorkerProcess()()() | Close the ASP .NET Worker process. W3WP with Windows 2003.
 | VirtualDirectoryExists(String, String) | Return true if the virtual directory exits.
 | W3WP_PROCESS | Windows 2003 ASP.NET process name
Inheritance Hierarchy
Object
IISUtils


ASP_NET_WP_PROCESS Field

ASP_NET_WP_PROCESS Field
Namespaces ► Devolutions.Utils ► IISUtils ► ASP_NET_WP_PROCESS
Windows XP, Windows 2000 ASP.NET process name
Declaration Syntax
C# Visual Basic Visual C++
public const string ASP_NET_WP_PROCESS
Public Const ASP_NET_WP_PROCESS As String
public:
literal String^ ASP_NET_WP_PROCESS


CreateVirtualDirectory Method (aRootFolder, aVirtualDirectoryName, aDirectory)

CreateVirtualDirectory Method (aRootFolder, aVirtualDirectoryName, aDirectory)
Namespaces ► Devolutions.Utils ► IISUtils ► CreateVirtualDirectory(String, String, String)
Create a new virtual directory.
Declaration Syntax
C# Visual Basic Visual C++
public static void CreateVirtualDirectory(
    string aRootFolder,
    string aVirtualDirectoryName,
    string aDirectory
)
Public Shared Sub CreateVirtualDirectory ( _
    aRootFolder As String, _
    aVirtualDirectoryName As String, _
    aDirectory As String _
)
public:
static void CreateVirtualDirectory(
    String^ aRootFolder,
    String^ aVirtualDirectoryName,
    String^ aDirectory
)
Parameters
aRootFolder (String)
aVirtualDirectoryName (String)
aDirectory (String)


DEFAULT_IIS_ROOT_FOLDER Field

DEFAULT_IIS_ROOT_FOLDER Field
Namespaces ► Devolutions.Utils ► IISUtils ► DEFAULT_IIS_ROOT_FOLDER
Default IIS Root
Declaration Syntax
C# Visual Basic Visual C++
public const string DEFAULT_IIS_ROOT_FOLDER
Public Const DEFAULT_IIS_ROOT_FOLDER As String
public:
literal String^ DEFAULT_IIS_ROOT_FOLDER


GetVirtualDirectory Method (aRootFolder, aVirtualDirectoryName)

GetVirtualDirectory Method (aRootFolder, aVirtualDirectoryName)
Namespaces ► Devolutions.Utils ► IISUtils ► GetVirtualDirectory(String, String)
Return the Directory Information for a virtual directory.
Declaration Syntax
C# Visual Basic Visual C++
public static DirectoryEntry GetVirtualDirectory(
    string aRootFolder,
    string aVirtualDirectoryName
)
Public Shared Function GetVirtualDirectory ( _
    aRootFolder As String, _
    aVirtualDirectoryName As String _
) As DirectoryEntry
public:
static DirectoryEntry^ GetVirtualDirectory(
    String^ aRootFolder,
    String^ aVirtualDirectoryName
)
Parameters
aRootFolder (String)
aVirtualDirectoryName (String)
Return Value


GetVirtualDirectoryList Method

GetVirtualDirectoryList Method
Namespaces ► Devolutions.Utils ► IISUtils ► GetVirtualDirectoryList()()()
Return the list of all the installed local Virtual Directory
Declaration Syntax
C# Visual Basic Visual C++
public static string[] GetVirtualDirectoryList()
Public Shared Function GetVirtualDirectoryList As String()
public:
static array<String^>^ GetVirtualDirectoryList()
Return Value


IIS_SERVICE_NAME Field

IIS_SERVICE_NAME Field
Namespaces ► Devolutions.Utils ► IISUtils ► IIS_SERVICE_NAME
IIS Service name
Declaration Syntax
C# Visual Basic Visual C++
public const string IIS_SERVICE_NAME
Public Const IIS_SERVICE_NAME As String
public:
literal String^ IIS_SERVICE_NAME


IISVersion Property

IISVersion Property
Namespaces ► Devolutions.Utils ► IISUtils ► IISVersion
Return the installed IIS version or null if not installed
Declaration Syntax
C# Visual Basic Visual C++
public static string IISVersion { get; }
Public Shared ReadOnly Property IISVersion As String
public:
static property String^ IISVersion {
    String^ get ();
}


IsIISServiceRunning Property

IsIISServiceRunning Property
Namespaces ► Devolutions.Utils ► IISUtils ► IsIISServiceRunning
Indicate if IIS is running.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsIISServiceRunning { get; }
Public Shared ReadOnly Property IsIISServiceRunning As Boolean
public:
static property bool IsIISServiceRunning {
    bool get ();
}


OpenIISManager Method

OpenIISManager Method
Namespaces ► Devolutions.Utils ► IISUtils ► OpenIISManager()()()
Open the IIS Manager property window.
Declaration Syntax
C# Visual Basic Visual C++
public static void OpenIISManager()
Public Shared Sub OpenIISManager
public:
static void OpenIISManager()


ReadAllProperties Method (aRootFolder, aDirectoryName)

ReadAllProperties Method (aRootFolder, aDirectoryName)
Namespaces ► Devolutions.Utils ► IISUtils ► ReadAllProperties(String, String)
Return all the informations for a virtual directory.
Declaration Syntax
C# Visual Basic Visual C++
public static string ReadAllProperties(
    string aRootFolder,
    string aDirectoryName
)
Public Shared Function ReadAllProperties ( _
    aRootFolder As String, _
    aDirectoryName As String _
) As String
public:
static String^ ReadAllProperties(
    String^ aRootFolder,
    String^ aDirectoryName
)
Parameters
aRootFolder (String)
aDirectoryName (String)
Return Value


SetDirectoryBrowsing Method (aDirName, aEnabled)

SetDirectoryBrowsing Method (aDirName, aEnabled)
Namespaces ► Devolutions.Utils ► IISUtils ► SetDirectoryBrowsing(String, Boolean)
Change the directory browsing value for a virtual directory.
Declaration Syntax
C# Visual Basic Visual C++
public static void SetDirectoryBrowsing(
    string aDirName,
    bool aEnabled
)
Public Shared Sub SetDirectoryBrowsing ( _
    aDirName As String, _
    aEnabled As Boolean _
)
public:
static void SetDirectoryBrowsing(
    String^ aDirName,
    bool aEnabled
)
Parameters
aDirName (String)
aEnabled (Boolean)


SetVirtualDirectoryProperty Method (aVirtualDirectory, aPropertyName, aValue)

SetVirtualDirectoryProperty Method (aVirtualDirectory, aPropertyName, aValue)
Namespaces ► Devolutions.Utils ► IISUtils ► SetVirtualDirectoryProperty(DirectoryEntry, String, Object)
Change a virtual directory property.
Declaration Syntax
C# Visual Basic Visual C++
public static bool SetVirtualDirectoryProperty(
    DirectoryEntry aVirtualDirectory,
    string aPropertyName,
    Object aValue
)
Public Shared Function SetVirtualDirectoryProperty ( _
    aVirtualDirectory As DirectoryEntry, _
    aPropertyName As String, _
    aValue As Object _
) As Boolean
public:
static bool SetVirtualDirectoryProperty(
    DirectoryEntry^ aVirtualDirectory,
    String^ aPropertyName,
    Object^ aValue
)
Parameters
aVirtualDirectory (DirectoryEntry)
aPropertyName (String)
aValue (Object)
Return Value


StartIIS Method

StartIIS Method
Namespaces ► Devolutions.Utils ► IISUtils ► StartIIS()()()
Start the IIS Service.
Declaration Syntax
C# Visual Basic Visual C++
public static void StartIIS()
Public Shared Sub StartIIS
public:
static void StartIIS()


StopIIS Method

StopIIS Method
Namespaces ► Devolutions.Utils ► IISUtils ► StopIIS()()()
Stop the IIS Service.
Declaration Syntax
C# Visual Basic Visual C++
public static void StopIIS()
Public Shared Sub StopIIS
public:
static void StopIIS()


SwitchVirtualDirectoryToADirectory Method

SwitchVirtualDirectoryToADirectory Method
Namespaces ► Devolutions.Utils ► IISUtils ► SwitchVirtualDirectoryToADirectory()()()
Members
Icon | Member | Description
 | SwitchVirtualDirectoryToADirectory(String) | Set a virtual directory to a folder.
 | SwitchVirtualDirectoryToADirectory(String, String) | Set a virtual directory to a folder.


SwitchVirtualDirectoryToADirectory Method (aRootFolder, aVirtualDirectoryName)

SwitchVirtualDirectoryToADirectory Method (aRootFolder, aVirtualDirectoryName)
Namespaces ► Devolutions.Utils ► IISUtils ► SwitchVirtualDirectoryToADirectory(String, String)
Set a virtual directory to a folder.
Declaration Syntax
C# Visual Basic Visual C++
public static bool SwitchVirtualDirectoryToADirectory(
    string aRootFolder,
    string aVirtualDirectoryName
)
Public Shared Function SwitchVirtualDirectoryToADirectory ( _
    aRootFolder As String, _
    aVirtualDirectoryName As String _
) As Boolean
public:
static bool SwitchVirtualDirectoryToADirectory(
    String^ aRootFolder,
    String^ aVirtualDirectoryName
)
Parameters
aRootFolder (String)
aVirtualDirectoryName (String)
Return Value


SwitchVirtualDirectoryToADirectory Method (aVirtualDirectoryName)

SwitchVirtualDirectoryToADirectory Method (aVirtualDirectoryName)
Namespaces ► Devolutions.Utils ► IISUtils ► SwitchVirtualDirectoryToADirectory(String)
Set a virtual directory to a folder.
Declaration Syntax
C# Visual Basic Visual C++
public static bool SwitchVirtualDirectoryToADirectory(
    string aVirtualDirectoryName
)
Public Shared Function SwitchVirtualDirectoryToADirectory ( _
    aVirtualDirectoryName As String _
) As Boolean
public:
static bool SwitchVirtualDirectoryToADirectory(
    String^ aVirtualDirectoryName
)
Parameters
aVirtualDirectoryName (String)
Return Value


SwitchVirtualDirectoryToARedirection Method

SwitchVirtualDirectoryToARedirection Method
Namespaces ► Devolutions.Utils ► IISUtils ► SwitchVirtualDirectoryToARedirection()()()
Members
Icon | Member | Description
 | SwitchVirtualDirectoryToARedirection(String, String) | Set a redirection to a virtual directory
 | SwitchVirtualDirectoryToARedirection(String, String, String) | Set a redirection to a virtual directory


SwitchVirtualDirectoryToARedirection Method (aRootFolder, aVirtualDirectoryName, aRedirectionURL)

SwitchVirtualDirectoryToARedirection Method (aRootFolder, aVirtualDirectoryName, aRedirectionURL)
Namespaces ► Devolutions.Utils ► IISUtils ► SwitchVirtualDirectoryToARedirection(String, String, String)
Set a redirection to a virtual directory
Declaration Syntax
C# Visual Basic Visual C++
public static bool SwitchVirtualDirectoryToARedirection(
    string aRootFolder,
    string aVirtualDirectoryName,
    string aRedirectionURL
)
Public Shared Function SwitchVirtualDirectoryToARedirection ( _
    aRootFolder As String, _
    aVirtualDirectoryName As String, _
    aRedirectionURL As String _
) As Boolean
public:
static bool SwitchVirtualDirectoryToARedirection(
    String^ aRootFolder,
    String^ aVirtualDirectoryName,
    String^ aRedirectionURL
)
Parameters
aRootFolder (String)
aVirtualDirectoryName (String)
aRedirectionURL (String)
Return Value


SwitchVirtualDirectoryToARedirection Method (aVirtualDirectoryName, aRedirectionURL)

SwitchVirtualDirectoryToARedirection Method (aVirtualDirectoryName, aRedirectionURL)
Namespaces ► Devolutions.Utils ► IISUtils ► SwitchVirtualDirectoryToARedirection(String, String)
Set a redirection to a virtual directory
Declaration Syntax
C# Visual Basic Visual C++
public static bool SwitchVirtualDirectoryToARedirection(
    string aVirtualDirectoryName,
    string aRedirectionURL
)
Public Shared Function SwitchVirtualDirectoryToARedirection ( _
    aVirtualDirectoryName As String, _
    aRedirectionURL As String _
) As Boolean
public:
static bool SwitchVirtualDirectoryToARedirection(
    String^ aVirtualDirectoryName,
    String^ aRedirectionURL
)
Parameters
aVirtualDirectoryName (String)
aRedirectionURL (String)
Return Value


TerminateAspWorkerProcess Method

TerminateAspWorkerProcess Method
Namespaces ► Devolutions.Utils ► IISUtils ► TerminateAspWorkerProcess()()()
Close the ASP .NET Worker process. W3WP with Windows 2003.
Declaration Syntax
C# Visual Basic Visual C++
public static bool TerminateAspWorkerProcess()
Public Shared Function TerminateAspWorkerProcess As Boolean
public:
static bool TerminateAspWorkerProcess()
Return Value


VirtualDirectoryExists Method (aRootFolder, aVirtualDirectoryName)

VirtualDirectoryExists Method (aRootFolder, aVirtualDirectoryName)
Namespaces ► Devolutions.Utils ► IISUtils ► VirtualDirectoryExists(String, String)
Return true if the virtual directory exits.
Declaration Syntax
C# Visual Basic Visual C++
public static bool VirtualDirectoryExists(
    string aRootFolder,
    string aVirtualDirectoryName
)
Public Shared Function VirtualDirectoryExists ( _
    aRootFolder As String, _
    aVirtualDirectoryName As String _
) As Boolean
public:
static bool VirtualDirectoryExists(
    String^ aRootFolder,
    String^ aVirtualDirectoryName
)
Parameters
aRootFolder (String)
aVirtualDirectoryName (String)
Return Value


W3WP_PROCESS Field

W3WP_PROCESS Field
Namespaces ► Devolutions.Utils ► IISUtils ► W3WP_PROCESS
Windows 2003 ASP.NET process name
Declaration Syntax
C# Visual Basic Visual C++
public const string W3WP_PROCESS
Public Const W3WP_PROCESS As String
public:
literal String^ W3WP_PROCESS


ImageUtils Class

ImageUtils Class
Namespaces ► Devolutions.Utils ► ImageUtils
This class contains the Image utility functions.
Declaration Syntax
C# Visual Basic Visual C++
public static class ImageUtils
Public NotInheritable Class ImageUtils
public ref class ImageUtils abstract sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DesktopIcon | Retreive the desktop icon
 | GetIcon(String, Boolean, Boolean) | Return the related file Windows icon
 | IconToBitmap(Icon) | Convert correctly icon to bitmap with alpha blending support
Inheritance Hierarchy
Object
ImageUtils


DesktopIcon Property

DesktopIcon Property
Namespaces ► Devolutions.Utils ► ImageUtils ► DesktopIcon
Retreive the desktop icon
Declaration Syntax
C# Visual Basic Visual C++
public static Icon DesktopIcon { get; }
Public Shared ReadOnly Property DesktopIcon As Icon
public:
static property Icon^ DesktopIcon {
    Icon^ get ();
}
Return Value


GetIcon Method (aPath, aSelected, aSmall)

GetIcon Method (aPath, aSelected, aSmall)
Namespaces ► Devolutions.Utils ► ImageUtils ► GetIcon(String, Boolean, Boolean)
Return the related file Windows icon
Declaration Syntax
C# Visual Basic Visual C++
public static Icon GetIcon(
    string aPath,
    bool aSelected,
    bool aSmall
)
Public Shared Function GetIcon ( _
    aPath As String, _
    aSelected As Boolean, _
    aSmall As Boolean _
) As Icon
public:
static Icon^ GetIcon(
    String^ aPath,
    bool aSelected,
    bool aSmall
)
Parameters
aPath (String)
aSelected (Boolean)
aSmall (Boolean)
Return Value


IconToBitmap Method (aIcon)

IconToBitmap Method (aIcon)
Namespaces ► Devolutions.Utils ► ImageUtils ► IconToBitmap(Icon)
Convert correctly icon to bitmap with alpha blending support
Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap IconToBitmap(
    Icon aIcon
)
Public Shared Function IconToBitmap ( _
    aIcon As Icon _
) As Bitmap
public:
static Bitmap^ IconToBitmap(
    Icon^ aIcon
)
Parameters
aIcon (Icon)
Return Value


LogUtils Class

LogUtils Class
Namespaces ► Devolutions.Utils ► LogUtils
Basic file logger with multithreading support
Declaration Syntax
C# Visual Basic Visual C++
public class LogUtils
Public Class LogUtils
public ref class LogUtils
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LogUtils()()() |
 | Debug(String) | Log an debug information.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error(Exception) | Log an error.
 | Error(String) | Log an error.
 | Error(String, Exception) | Log an error.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Info(String) | Log an information.
 | LogFileName | Get or set the log filename, by default it the entry assembly name with a .log file extension.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Warn(String) | Log a warning.
Inheritance Hierarchy
Object
LogUtils


Debug Method (aMessage)

Debug Method (aMessage)
Namespaces ► Devolutions.Utils ► LogUtils ► Debug(String)
Log an debug information.
Declaration Syntax
C# Visual Basic Visual C++
public static void Debug(
    string aMessage
)
Public Shared Sub Debug ( _
    aMessage As String _
)
public:
static void Debug(
    String^ aMessage
)
Parameters
aMessage (String)


Error Method

Error Method
Namespaces ► Devolutions.Utils ► LogUtils ► Error()()()
Members
Icon | Member | Description
 | Error(Exception) | Log an error.
 | Error(String) | Log an error.
 | Error(String, Exception) | Log an error.


Error Method (aException)

Error Method (aException)
Namespaces ► Devolutions.Utils ► LogUtils ► Error(Exception)
Log an error.
Declaration Syntax
C# Visual Basic Visual C++
public static void Error(
    Exception aException
)
Public Shared Sub Error ( _
    aException As Exception _
)
public:
static void Error(
    Exception^ aException
)
Parameters
aException (Exception)


Error Method (aMessage)

Error Method (aMessage)
Namespaces ► Devolutions.Utils ► LogUtils ► Error(String)
Log an error.
Declaration Syntax
C# Visual Basic Visual C++
public static void Error(
    string aMessage
)
Public Shared Sub Error ( _
    aMessage As String _
)
public:
static void Error(
    String^ aMessage
)
Parameters
aMessage (String)


Error Method (aMessage, aException)

Error Method (aMessage, aException)
Namespaces ► Devolutions.Utils ► LogUtils ► Error(String, Exception)
Log an error.
Declaration Syntax
C# Visual Basic Visual C++
public static void Error(
    string aMessage,
    Exception aException
)
Public Shared Sub Error ( _
    aMessage As String, _
    aException As Exception _
)
public:
static void Error(
    String^ aMessage,
    Exception^ aException
)
Parameters
aMessage (String)
aException (Exception)


Info Method (aMessage)

Info Method (aMessage)
Namespaces ► Devolutions.Utils ► LogUtils ► Info(String)
Log an information.
Declaration Syntax
C# Visual Basic Visual C++
public static void Info(
    string aMessage
)
Public Shared Sub Info ( _
    aMessage As String _
)
public:
static void Info(
    String^ aMessage
)
Parameters
aMessage (String)


LogFileName Property

LogFileName Property
Namespaces ► Devolutions.Utils ► LogUtils ► LogFileName
Get or set the log filename, by default it the entry assembly name with a .log file extension.
Declaration Syntax
C# Visual Basic Visual C++
public static string LogFileName { get; set; }
Public Shared Property LogFileName As String
public:
static property String^ LogFileName {
    String^ get ();
    void set (String^ value);
}


LogUtils Constructor

LogUtils Constructor
Namespaces ► Devolutions.Utils ► LogUtils ► LogUtils()()()
Declaration Syntax
C# Visual Basic Visual C++
public LogUtils()
Public Sub New
public:
LogUtils()


Warn Method (aMessage)

Warn Method (aMessage)
Namespaces ► Devolutions.Utils ► LogUtils ► Warn(String)
Log a warning.
Declaration Syntax
C# Visual Basic Visual C++
public static void Warn(
    string aMessage
)
Public Shared Sub Warn ( _
    aMessage As String _
)
public:
static void Warn(
    String^ aMessage
)
Parameters
aMessage (String)


OfficeUtils Class

OfficeUtils Class
Namespaces ► Devolutions.Utils ► OfficeUtils
This class contains the basic Office utility functions.
Declaration Syntax
C# Visual Basic Visual C++
public static class OfficeUtils
Public NotInheritable Class OfficeUtils
public ref class OfficeUtils abstract sealed
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | OfficeVersion | Return the current Office version using Late Binding (slow)
Inheritance Hierarchy
Object
OfficeUtils


OfficeVersion Property

OfficeVersion Property
Namespaces ► Devolutions.Utils ► OfficeUtils ► OfficeVersion
Return the current Office version using Late Binding (slow)
Declaration Syntax
C# Visual Basic Visual C++
public static string OfficeVersion { get; }
Public Shared ReadOnly Property OfficeVersion As String
public:
static property String^ OfficeVersion {
    String^ get ();
}


ReflectionUtils Class

ReflectionUtils Class
Namespaces ► Devolutions.Utils ► ReflectionUtils
This class contains the reflection utility functions.
Declaration Syntax
C# Visual Basic Visual C++
public static class ReflectionUtils
Public NotInheritable Class ReflectionUtils
public ref class ReflectionUtils abstract sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AssemblyCompany | Return the executing assembly company
 | AssemblyCopyright | Return the executing assembly copyright
 | AssemblyDescription | Return the executing assembly description
 | AssemblyFilePath | Return the executing assembly path
 | AssemblyProduct | Return the executing assembly product name
 | AssemblyVersion | Return the executing assembly version
 | GetCurrentMethodName()()() | Return the current executing Method in the stack trace.
 | GetPropertyValue(Object, String) | Return the value of public or private property in an object by using reflection
 | ReadFieldValue(Object, String) | Return the value of public or private field in an object by using reflection
Inheritance Hierarchy
Object
ReflectionUtils


AssemblyCompany Property

AssemblyCompany Property
Namespaces ► Devolutions.Utils ► ReflectionUtils ► AssemblyCompany
Return the executing assembly company
Declaration Syntax
C# Visual Basic Visual C++
public static string AssemblyCompany { get; }
Public Shared ReadOnly Property AssemblyCompany As String
public:
static property String^ AssemblyCompany {
    String^ get ();
}


AssemblyCopyright Property

AssemblyCopyright Property
Namespaces ► Devolutions.Utils ► ReflectionUtils ► AssemblyCopyright
Return the executing assembly copyright
Declaration Syntax
C# Visual Basic Visual C++
public static string AssemblyCopyright { get; }
Public Shared ReadOnly Property AssemblyCopyright As String
public:
static property String^ AssemblyCopyright {
    String^ get ();
}


AssemblyDescription Property

AssemblyDescription Property
Namespaces ► Devolutions.Utils ► ReflectionUtils ► AssemblyDescription
Return the executing assembly description
Declaration Syntax
C# Visual Basic Visual C++
public static string AssemblyDescription { get; }
Public Shared ReadOnly Property AssemblyDescription As String
public:
static property String^ AssemblyDescription {
    String^ get ();
}


AssemblyFilePath Property

AssemblyFilePath Property
Namespaces ► Devolutions.Utils ► ReflectionUtils ► AssemblyFilePath
Return the executing assembly path
Declaration Syntax
C# Visual Basic Visual C++
public static string AssemblyFilePath { get; }
Public Shared ReadOnly Property AssemblyFilePath As String
public:
static property String^ AssemblyFilePath {
    String^ get ();
}
Return Value


AssemblyProduct Property

AssemblyProduct Property
Namespaces ► Devolutions.Utils ► ReflectionUtils ► AssemblyProduct
Return the executing assembly product name
Declaration Syntax
C# Visual Basic Visual C++
public static string AssemblyProduct { get; }
Public Shared ReadOnly Property AssemblyProduct As String
public:
static property String^ AssemblyProduct {
    String^ get ();
}


AssemblyVersion Property

AssemblyVersion Property
Namespaces ► Devolutions.Utils ► ReflectionUtils ► AssemblyVersion
Return the executing assembly version
Declaration Syntax
C# Visual Basic Visual C++
public static Version AssemblyVersion { get; }
Public Shared ReadOnly Property AssemblyVersion As Version
public:
static property Version^ AssemblyVersion {
    Version^ get ();
}


GetCurrentMethodName Method

GetCurrentMethodName Method
Namespaces ► Devolutions.Utils ► ReflectionUtils ► GetCurrentMethodName()()()
Return the current executing Method in the stack trace.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetCurrentMethodName()
Public Shared Function GetCurrentMethodName As String
public:
static String^ GetCurrentMethodName()
Return Value


GetPropertyValue Method (aValue, aPropertyName)

GetPropertyValue Method (aValue, aPropertyName)
Namespaces ► Devolutions.Utils ► ReflectionUtils ► GetPropertyValue(Object, String)
Return the value of public or private property in an object by using reflection
Declaration Syntax
C# Visual Basic Visual C++
public static Object GetPropertyValue(
    Object aValue,
    string aPropertyName
)
Public Shared Function GetPropertyValue ( _
    aValue As Object, _
    aPropertyName As String _
) As Object
public:
static Object^ GetPropertyValue(
    Object^ aValue,
    String^ aPropertyName
)
Parameters
aValue (Object)
aPropertyName (String)
Return Value


ReadFieldValue Method (aValue, aFieldName)

ReadFieldValue Method (aValue, aFieldName)
Namespaces ► Devolutions.Utils ► ReflectionUtils ► ReadFieldValue(Object, String)
Return the value of public or private field in an object by using reflection
Declaration Syntax
C# Visual Basic Visual C++
public static Object ReadFieldValue(
    Object aValue,
    string aFieldName
)
Public Shared Function ReadFieldValue ( _
    aValue As Object, _
    aFieldName As String _
) As Object
public:
static Object^ ReadFieldValue(
    Object^ aValue,
    String^ aFieldName
)
Parameters
aValue (Object)
aFieldName (String)
Return Value


RegistryUtils Class

RegistryUtils Class
Namespaces ► Devolutions.Utils ► RegistryUtils
This class contains the registry utility functions.
Declaration Syntax
C# Visual Basic Visual C++
public static class RegistryUtils
Public NotInheritable Class RegistryUtils
public ref class RegistryUtils abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetBytesValue(RegistryKey, String, String) | Return a binary value from the registry.
 | GetIntegerValue(RegistryKey, String, String) | Return a int value from the registry.
 | GetRegistryValue<(Of <(T>)>)(RegistryHive, String, String, RegistryValueKind, T%) | Return the a registry value from a Hive
 | GetStringValue(RegistryKey, String, String) | Return a string value from the registry.
 | GetValue(RegistryKey, String, String) | Return a value from the registry.
 | SetBinaryValue(RegistryKey, String, String, array<Byte>[]()[]) | Save a binary value in the registry. The SubKey will be created if it does not exists.
 | SetIntegerValue(RegistryKey, String, String, Int32) | Save a integer value in the registry. The SubKey will be created if it does not exists.
 | SetStringValue(RegistryKey, String, String, String) | Save a string value in the registry. The SubKey will be created if it does not exists.
 | SetValue(RegistryKey, String, String, Object, RegistryValueKind) | Save a value in the registry. The SubKey will be created if it does not exists.
Inheritance Hierarchy
Object
RegistryUtils


GetBytesValue Method (aRegistryKey, aSubKey, aName)

GetBytesValue Method (aRegistryKey, aSubKey, aName)
Namespaces ► Devolutions.Utils ► RegistryUtils ► GetBytesValue(RegistryKey, String, String)
Return a binary value from the registry.
Declaration Syntax
C# Visual Basic Visual C++
public static byte[] GetBytesValue(
    RegistryKey aRegistryKey,
    string aSubKey,
    string aName
)
Public Shared Function GetBytesValue ( _
    aRegistryKey As RegistryKey, _
    aSubKey As String, _
    aName As String _
) As Byte()
public:
static array<unsigned char>^ GetBytesValue(
    RegistryKey^ aRegistryKey,
    String^ aSubKey,
    String^ aName
)
Parameters
aRegistryKey (RegistryKey)
aSubKey (String)
aName (String)
Return Value


GetIntegerValue Method (aRegistryKey, aSubKey, aName)

GetIntegerValue Method (aRegistryKey, aSubKey, aName)
Namespaces ► Devolutions.Utils ► RegistryUtils ► GetIntegerValue(RegistryKey, String, String)
Return a int value from the registry.
Declaration Syntax
C# Visual Basic Visual C++
public static Nullable<int> GetIntegerValue(
    RegistryKey aRegistryKey,
    string aSubKey,
    string aName
)
Public Shared Function GetIntegerValue ( _
    aRegistryKey As RegistryKey, _
    aSubKey As String, _
    aName As String _
) As Nullable(Of Integer)
public:
static Nullable<int> GetIntegerValue(
    RegistryKey^ aRegistryKey,
    String^ aSubKey,
    String^ aName
)
Parameters
aRegistryKey (RegistryKey)
aSubKey (String)
aName (String)
Return Value


GetRegistryValue Method (aHive, aKey, aValue, aKind, aData)

GetRegistryValue<(Of <(T>)>) Method (aHive, aKey, aValue, aKind, aData)
Namespaces ► Devolutions.Utils ► RegistryUtils ► GetRegistryValue<(Of <(T>)>)(RegistryHive, String, String, RegistryValueKind, T%)
Return the a registry value from a Hive
Declaration Syntax
C# Visual Basic Visual C++
public static bool GetRegistryValue<T>(
    RegistryHive aHive,
    string aKey,
    string aValue,
    RegistryValueKind aKind,
    out T aData
)

Public Shared Function GetRegistryValue(Of T) ( _
    aHive As RegistryHive, _
    aKey As String, _
    aValue As String, _
    aKind As RegistryValueKind, _
    <OutAttribute> ByRef aData As T _
) As Boolean
public:
generic<typename T>
static bool GetRegistryValue(
    RegistryHive aHive,
    String^ aKey,
    String^ aValue,
    RegistryValueKind aKind,
    [OutAttribute] T% aData
)
Generic Template Parameters
T
Parameters
aHive (RegistryHive)
aKey (String)
aValue (String)
aKind (RegistryValueKind)
aData ( T %)
Return Value


GetStringValue Method (aRegistryKey, aSubKey, aName)

GetStringValue Method (aRegistryKey, aSubKey, aName)
Namespaces ► Devolutions.Utils ► RegistryUtils ► GetStringValue(RegistryKey, String, String)
Return a string value from the registry.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetStringValue(
    RegistryKey aRegistryKey,
    string aSubKey,
    string aName
)
Public Shared Function GetStringValue ( _
    aRegistryKey As RegistryKey, _
    aSubKey As String, _
    aName As String _
) As String
public:
static String^ GetStringValue(
    RegistryKey^ aRegistryKey,
    String^ aSubKey,
    String^ aName
)
Parameters
aRegistryKey (RegistryKey)
aSubKey (String)
aName (String)
Return Value


GetValue Method (aRegistryKey, aSubKey, aName)

GetValue Method (aRegistryKey, aSubKey, aName)
Namespaces ► Devolutions.Utils ► RegistryUtils ► GetValue(RegistryKey, String, String)
Return a value from the registry.
Declaration Syntax
C# Visual Basic Visual C++
public static Object GetValue(
    RegistryKey aRegistryKey,
    string aSubKey,
    string aName
)
Public Shared Function GetValue ( _
    aRegistryKey As RegistryKey, _
    aSubKey As String, _
    aName As String _
) As Object
public:
static Object^ GetValue(
    RegistryKey^ aRegistryKey,
    String^ aSubKey,
    String^ aName
)
Parameters
aRegistryKey (RegistryKey)
aSubKey (String)
aName (String)
Return Value


SetBinaryValue Method (aRegistryKey, aSubKey, aName, aValue)

SetBinaryValue Method (aRegistryKey, aSubKey, aName, aValue)
Namespaces ► Devolutions.Utils ► RegistryUtils ► SetBinaryValue(RegistryKey, String, String, array<Byte>[]()[])
Save a binary value in the registry. The SubKey will be created if it does not exists.
Declaration Syntax
C# Visual Basic Visual C++
public static void SetBinaryValue(
    RegistryKey aRegistryKey,
    string aSubKey,
    string aName,
    byte[] aValue
)
Public Shared Sub SetBinaryValue ( _
    aRegistryKey As RegistryKey, _
    aSubKey As String, _
    aName As String, _
    aValue As Byte() _
)
public:
static void SetBinaryValue(
    RegistryKey^ aRegistryKey,
    String^ aSubKey,
    String^ aName,
    array<unsigned char>^ aValue
)
Parameters
aRegistryKey (RegistryKey)
aSubKey (String)
aName (String)
aValue (array< Byte >[]()[])


SetIntegerValue Method (aRegistryKey, aSubKey, aName, aValue)

SetIntegerValue Method (aRegistryKey, aSubKey, aName, aValue)
Namespaces ► Devolutions.Utils ► RegistryUtils ► SetIntegerValue(RegistryKey, String, String, Int32)
Save a integer value in the registry. The SubKey will be created if it does not exists.
Declaration Syntax
C# Visual Basic Visual C++
public static void SetIntegerValue(
    RegistryKey aRegistryKey,
    string aSubKey,
    string aName,
    int aValue
)
Public Shared Sub SetIntegerValue ( _
    aRegistryKey As RegistryKey, _
    aSubKey As String, _
    aName As String, _
    aValue As Integer _
)
public:
static void SetIntegerValue(
    RegistryKey^ aRegistryKey,
    String^ aSubKey,
    String^ aName,
    int aValue
)
Parameters
aRegistryKey (RegistryKey)
aSubKey (String)
aName (String)
aValue (Int32)


SetStringValue Method (aRegistryKey, aSubKey, aName, aValue)

SetStringValue Method (aRegistryKey, aSubKey, aName, aValue)
Namespaces ► Devolutions.Utils ► RegistryUtils ► SetStringValue(RegistryKey, String, String, String)
Save a string value in the registry. The SubKey will be created if it does not exists.
Declaration Syntax
C# Visual Basic Visual C++
public static void SetStringValue(
    RegistryKey aRegistryKey,
    string aSubKey,
    string aName,
    string aValue
)
Public Shared Sub SetStringValue ( _
    aRegistryKey As RegistryKey, _
    aSubKey As String, _
    aName As String, _
    aValue As String _
)
public:
static void SetStringValue(
    RegistryKey^ aRegistryKey,
    String^ aSubKey,
    String^ aName,
    String^ aValue
)
Parameters
aRegistryKey (RegistryKey)
aSubKey (String)
aName (String)
aValue (String)


SetValue Method (aRegistryKey, aSubKey, aName, aValue, aRegistryValueKind)

SetValue Method (aRegistryKey, aSubKey, aName, aValue, aRegistryValueKind)
Namespaces ► Devolutions.Utils ► RegistryUtils ► SetValue(RegistryKey, String, String, Object, RegistryValueKind)
Save a value in the registry. The SubKey will be created if it does not exists.
Declaration Syntax
C# Visual Basic Visual C++
public static void SetValue(
    RegistryKey aRegistryKey,
    string aSubKey,
    string aName,
    Object aValue,
    RegistryValueKind aRegistryValueKind
)
Public Shared Sub SetValue ( _
    aRegistryKey As RegistryKey, _
    aSubKey As String, _
    aName As String, _
    aValue As Object, _
    aRegistryValueKind As RegistryValueKind _
)
public:
static void SetValue(
    RegistryKey^ aRegistryKey,
    String^ aSubKey,
    String^ aName,
    Object^ aValue,
    RegistryValueKind aRegistryValueKind
)
Parameters
aRegistryKey (RegistryKey)
aSubKey (String)
aName (String)
aValue (Object)
aRegistryValueKind (RegistryValueKind)


SerializationUtils Class

SerializationUtils Class
Namespaces ► Devolutions.Utils ► SerializationUtils
This class contains the serialization utility functions.
Declaration Syntax
C# Visual Basic Visual C++
public static class SerializationUtils
Public NotInheritable Class SerializationUtils
public ref class SerializationUtils abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LoadObjectFromFile(String, Type) | Read an object from an Xml file.
 | LoadObjectFromFile<(Of <(T>)>)(String) | Read an object T from a file
 | LoadObjectFromFile(String, Type, Boolean) | Read an object from an Xml file.
 | LoadObjectFromFile<(Of <(T>)>)(String, Boolean) | Read an object T from an Xml file.
 | LoadObjectFromString(String, Type, Boolean) | Read an object from a string.
 | LoadObjectFromString<(Of <(T>)>)(String, Boolean) | Read an object T from a string.
 | SaveObjectToFile(String, Object) | Save an object into an Xml file.
 | SaveObjectToString(Object) | Save an object into an Xml string.
Inheritance Hierarchy
Object
SerializationUtils


LoadObjectFromFile Method

LoadObjectFromFile Method
Namespaces ► Devolutions.Utils ► SerializationUtils ► LoadObjectFromFile()()()
Members
Icon | Member | Description
 | LoadObjectFromFile(String, Type) | Read an object from an Xml file.
 | LoadObjectFromFile<(Of <(T>)>)(String) | Read an object T from a file
 | LoadObjectFromFile(String, Type, Boolean) | Read an object from an Xml file.
 | LoadObjectFromFile<(Of <(T>)>)(String, Boolean) | Read an object T from an Xml file.


LoadObjectFromFile Method (aFileName)

LoadObjectFromFile<(Of <(T>)>) Method (aFileName)
Namespaces ► Devolutions.Utils ► SerializationUtils ► LoadObjectFromFile<(Of <(T>)>)(String)
Read an object T from a file
Declaration Syntax
C# Visual Basic Visual C++
public static T LoadObjectFromFile<T>(
    string aFileName
)

Public Shared Function LoadObjectFromFile(Of T) ( _
    aFileName As String _
) As T
public:
generic<typename T>
static T LoadObjectFromFile(
    String^ aFileName
)
Generic Template Parameters
T
Parameters
aFileName (String)
Return Value


LoadObjectFromFile Method (aFileName, aCreateAnInstanceIfNotExists)

LoadObjectFromFile<(Of <(T>)>) Method (aFileName, aCreateAnInstanceIfNotExists)
Namespaces ► Devolutions.Utils ► SerializationUtils ► LoadObjectFromFile<(Of <(T>)>)(String, Boolean)
Read an object T from an Xml file.
Declaration Syntax
C# Visual Basic Visual C++
public static T LoadObjectFromFile<T>(
    string aFileName,
    bool aCreateAnInstanceIfNotExists
)
where T : new()

Public Shared Function LoadObjectFromFile(Of T As New) ( _
    aFileName As String, _
    aCreateAnInstanceIfNotExists As Boolean _
) As T
public:
generic<typename T>
where T : gcnew()
static T LoadObjectFromFile(
    String^ aFileName,
    bool aCreateAnInstanceIfNotExists
)
Generic Template Parameters
T
Parameters
aFileName (String)
aCreateAnInstanceIfNotExists (Boolean)
Indicate if the method must create an empty instance if the file does not exists.
Return Value


LoadObjectFromFile Method (aFileName, aType)

LoadObjectFromFile Method (aFileName, aType)
Namespaces ► Devolutions.Utils ► SerializationUtils ► LoadObjectFromFile(String, Type)
Read an object from an Xml file.
Declaration Syntax
C# Visual Basic Visual C++
public static Object LoadObjectFromFile(
    string aFileName,
    Type aType
)
Public Shared Function LoadObjectFromFile ( _
    aFileName As String, _
    aType As Type _
) As Object
public:
static Object^ LoadObjectFromFile(
    String^ aFileName,
    Type^ aType
)
Parameters
aFileName (String)
aType (Type)
Return Value


LoadObjectFromFile Method (aFileName, aType, aCreateAnInstanceIfNotExists)

LoadObjectFromFile Method (aFileName, aType, aCreateAnInstanceIfNotExists)
Namespaces ► Devolutions.Utils ► SerializationUtils ► LoadObjectFromFile(String, Type, Boolean)
Read an object from an Xml file.
Declaration Syntax
C# Visual Basic Visual C++
public static Object LoadObjectFromFile(
    string aFileName,
    Type aType,
    bool aCreateAnInstanceIfNotExists
)
Public Shared Function LoadObjectFromFile ( _
    aFileName As String, _
    aType As Type, _
    aCreateAnInstanceIfNotExists As Boolean _
) As Object
public:
static Object^ LoadObjectFromFile(
    String^ aFileName,
    Type^ aType,
    bool aCreateAnInstanceIfNotExists
)
Parameters
aFileName (String)
aType (Type)
aCreateAnInstanceIfNotExists (Boolean)
Indicate if the method must create an empty instance if the file does not exists.
Return Value


LoadObjectFromString Method

LoadObjectFromString Method
Namespaces ► Devolutions.Utils ► SerializationUtils ► LoadObjectFromString()()()
Members
Icon | Member | Description
 | LoadObjectFromString(String, Type, Boolean) | Read an object from a string.
 | LoadObjectFromString<(Of <(T>)>)(String, Boolean) | Read an object T from a string.


LoadObjectFromString Method (aString, aCreateAnInstanceIfNotExists)

LoadObjectFromString<(Of <(T>)>) Method (aString, aCreateAnInstanceIfNotExists)
Namespaces ► Devolutions.Utils ► SerializationUtils ► LoadObjectFromString<(Of <(T>)>)(String, Boolean)
Read an object T from a string.
Declaration Syntax
C# Visual Basic Visual C++
public static T LoadObjectFromString<T>(
    string aString,
    bool aCreateAnInstanceIfNotExists
)
where T : new()

Public Shared Function LoadObjectFromString(Of T As New) ( _
    aString As String, _
    aCreateAnInstanceIfNotExists As Boolean _
) As T
public:
generic<typename T>
where T : gcnew()
static T LoadObjectFromString(
    String^ aString,
    bool aCreateAnInstanceIfNotExists
)
Generic Template Parameters
T
Parameters
aString (String)
aCreateAnInstanceIfNotExists (Boolean)
Return Value


LoadObjectFromString Method (aString, aType, aCreateAnInstanceIfNotExists)

LoadObjectFromString Method (aString, aType, aCreateAnInstanceIfNotExists)
Namespaces ► Devolutions.Utils ► SerializationUtils ► LoadObjectFromString(String, Type, Boolean)
Read an object from a string.
Declaration Syntax
C# Visual Basic Visual C++
public static Object LoadObjectFromString(
    string aString,
    Type aType,
    bool aCreateAnInstanceIfNotExists
)
Public Shared Function LoadObjectFromString ( _
    aString As String, _
    aType As Type, _
    aCreateAnInstanceIfNotExists As Boolean _
) As Object
public:
static Object^ LoadObjectFromString(
    String^ aString,
    Type^ aType,
    bool aCreateAnInstanceIfNotExists
)
Parameters
aString (String)
aType (Type)
aCreateAnInstanceIfNotExists (Boolean)
Return Value


SaveObjectToFile Method (aFileName, aValue)

SaveObjectToFile Method (aFileName, aValue)
Namespaces ► Devolutions.Utils ► SerializationUtils ► SaveObjectToFile(String, Object)
Save an object into an Xml file.
Declaration Syntax
C# Visual Basic Visual C++
public static void SaveObjectToFile(
    string aFileName,
    Object aValue
)
Public Shared Sub SaveObjectToFile ( _
    aFileName As String, _
    aValue As Object _
)
public:
static void SaveObjectToFile(
    String^ aFileName,
    Object^ aValue
)
Parameters
aFileName (String)
aValue (Object)


SaveObjectToString Method (aValue)

SaveObjectToString Method (aValue)
Namespaces ► Devolutions.Utils ► SerializationUtils ► SaveObjectToString(Object)
Save an object into an Xml string.
Declaration Syntax
C# Visual Basic Visual C++
public static string SaveObjectToString(
    Object aValue
)
Public Shared Function SaveObjectToString ( _
    aValue As Object _
) As String
public:
static String^ SaveObjectToString(
    Object^ aValue
)
Parameters
aValue (Object)


ServiceUtils Class

ServiceUtils Class
Namespaces ► Devolutions.Utils ► ServiceUtils
This class contains the Window Service utility functions.
Declaration Syntax
C# Visual Basic Visual C++
public static class ServiceUtils
Public NotInheritable Class ServiceUtils
public ref class ServiceUtils abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetServiceDisplayName()()() | Return the list of installed service in a string Array
 | GetServiceInstallationPath(String) | Return the installation path of an installed Windows service.
 | GetServiceNameList()()() | Return the list of installed service in a string Array
 | ServiceIsInstalled(String) | Check if a service is installed
 | ServiceIsRunning(String) | Check if a service is running
 | ServiceStartMode(String) | Return the service start mode
 | SetServiceStartMode(String, ServiceUtils..::.ServiceStart) | Set the service start mode
 | StartService(String) | Start a service
 | StopService(String) | Stop a service
Inheritance Hierarchy
Object
ServiceUtils


GetServiceDisplayName Method

GetServiceDisplayName Method
Namespaces ► Devolutions.Utils ► ServiceUtils ► GetServiceDisplayName()()()
Return the list of installed service in a string Array
Declaration Syntax
C# Visual Basic Visual C++
public static string[] GetServiceDisplayName()
Public Shared Function GetServiceDisplayName As String()
public:
static array<String^>^ GetServiceDisplayName()
Return Value


GetServiceInstallationPath Method (aName)

GetServiceInstallationPath Method (aName)
Namespaces ► Devolutions.Utils ► ServiceUtils ► GetServiceInstallationPath(String)
Return the installation path of an installed Windows service.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetServiceInstallationPath(
    string aName
)
Public Shared Function GetServiceInstallationPath ( _
    aName As String _
) As String
public:
static String^ GetServiceInstallationPath(
    String^ aName
)
Parameters
aName (String)
Return Value


GetServiceNameList Method

GetServiceNameList Method
Namespaces ► Devolutions.Utils ► ServiceUtils ► GetServiceNameList()()()
Return the list of installed service in a string Array
Declaration Syntax
C# Visual Basic Visual C++
public static string[] GetServiceNameList()
Public Shared Function GetServiceNameList As String()
public:
static array<String^>^ GetServiceNameList()
Return Value


ServiceIsInstalled Method (aName)

ServiceIsInstalled Method (aName)
Namespaces ► Devolutions.Utils ► ServiceUtils ► ServiceIsInstalled(String)
Check if a service is installed
Declaration Syntax
C# Visual Basic Visual C++
public static bool ServiceIsInstalled(
    string aName
)
Public Shared Function ServiceIsInstalled ( _
    aName As String _
) As Boolean
public:
static bool ServiceIsInstalled(
    String^ aName
)
Parameters
aName (String)
Return Value


ServiceIsRunning Method (aName)

ServiceIsRunning Method (aName)
Namespaces ► Devolutions.Utils ► ServiceUtils ► ServiceIsRunning(String)
Check if a service is running
Declaration Syntax
C# Visual Basic Visual C++
public static bool ServiceIsRunning(
    string aName
)
Public Shared Function ServiceIsRunning ( _
    aName As String _
) As Boolean
public:
static bool ServiceIsRunning(
    String^ aName
)
Parameters
aName (String)
Return Value


ServiceStartMode Method (aName)

ServiceStartMode Method (aName)
Namespaces ► Devolutions.Utils ► ServiceUtils ► ServiceStartMode(String)
Return the service start mode
Declaration Syntax
C# Visual Basic Visual C++
public static ServiceUtils..::.ServiceStart ServiceStartMode(
    string aName
)
Public Shared Function ServiceStartMode ( _
    aName As String _
) As ServiceUtils..::.ServiceStart
public:
static ServiceUtils..::.ServiceStart ServiceStartMode(
    String^ aName
)
Parameters
aName (String)
Return Value


SetServiceStartMode Method (aName, aStartMode)

SetServiceStartMode Method (aName, aStartMode)
Namespaces ► Devolutions.Utils ► ServiceUtils ► SetServiceStartMode(String, ServiceUtils..::.ServiceStart)
Set the service start mode
Declaration Syntax
C# Visual Basic Visual C++
public static bool SetServiceStartMode(
    string aName,
    ServiceUtils..::.ServiceStart aStartMode
)
Public Shared Function SetServiceStartMode ( _
    aName As String, _
    aStartMode As ServiceUtils..::.ServiceStart _
) As Boolean
public:
static bool SetServiceStartMode(
    String^ aName,
    ServiceUtils..::.ServiceStart aStartMode
)
Parameters
aName (String)
aStartMode (ServiceUtils..::.ServiceStart)
Return Value


StartService Method (aName)

StartService Method (aName)
Namespaces ► Devolutions.Utils ► ServiceUtils ► StartService(String)
Start a service
Declaration Syntax
C# Visual Basic Visual C++
public static bool StartService(
    string aName
)
Public Shared Function StartService ( _
    aName As String _
) As Boolean
public:
static bool StartService(
    String^ aName
)
Parameters
aName (String)
Return Value


StopService Method (aName)

StopService Method (aName)
Namespaces ► Devolutions.Utils ► ServiceUtils ► StopService(String)
Stop a service
Declaration Syntax
C# Visual Basic Visual C++
public static bool StopService(
    string aName
)
Public Shared Function StopService ( _
    aName As String _
) As Boolean
public:
static bool StopService(
    String^ aName
)
Parameters
aName (String)
Return Value


ServiceUtils.ServiceStart Enumeration

ServiceUtils..::.ServiceStart Enumeration
Namespaces ► Devolutions.Utils ► ServiceUtils ► ServiceUtils..::.ServiceStart
This enum contains all the service start mode
Declaration Syntax
C# Visual Basic Visual C++
public enum ServiceStart
Public Enumeration ServiceStart
public enum class ServiceStart
Members
Member | Description
Boot | Boot
System | System
Automatic | Automatic
Manual | Manual
Disabled | Disabled
Error | Error


SqlClientUtils Class

SqlClientUtils Class
Namespaces ► Devolutions.Utils ► SqlClientUtils
This class contains the SqlServer utility functions.
Declaration Syntax
C# Visual Basic Visual C++
public static class SqlClientUtils
Public NotInheritable Class SqlClientUtils
public ref class SqlClientUtils abstract sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BackupDatabase(String, String, String) | Create backup of an Sql Server Database.
 | BackupDatabase(String, String, String, Int32, Boolean) | Create backup of an Sql Server Database.
 | ChangeConnectionStringDatabase(String, String) | Change the database name from an existing connection string.
 | ChangeConnectionStringDatabaseToMaster(String) | Change the database name from an existing connection string to master.
 | CreateDatabase(String, String) | Create a new empty SqlServer database.
 | CreateSqlCommand(String) | Create and return a SqlCommand with the default Connection string
 | CreateSqlConnection()()() | Create an Sql Server connection with the default connection string.
 | DatabaseExists(String, String) | Check if a database exists.
 | DefaultConnectionString | Default connection string used.
 | DefaultSqlCommandTimeout | Default SQl command timeout used by SqlClientUtils. 30 seconds by default.
 | DropDatabase(String, String) | Drop an existing Sql Server database.
 | GetDatabaseFileInformation(String, String) | Return the Database file information (Name, FileName and FileSize).
 | GetDataSet(SqlCommand, Boolean, String) | Fill a dataset.
 | GetDataSet(String, array<SqlParameter>[]()[], Boolean, String) | Fill a dataset.
 | GetDataSet(String, String) | Fill a dataset.
 | GetTableFieldNames(String, String) | Return the field name for a specific table.
 | GetTableNames(String) | Return all the table names of a database.
 | GetTableRelations(String, String) | Return all the relations contained in a table.
 | GetViewNames(String) | Return all the views of a database.
 | KillDatabaseConnections(String, String) | Close all the connection for a database. Be carefull when using this method, it might causes problems if an external process uses the connection.
 | MoveDatabase(String, String, String) | Move physically the database from a folder to an other.
 | RestoreDatabase(String, String, String) | Restore a backup file.
 | RestoreDatabase(String, String, String, Int32) | Restore a backup file.
Inheritance Hierarchy
Object
SqlClientUtils


BackupDatabase Method

BackupDatabase Method
Namespaces ► Devolutions.Utils ► SqlClientUtils ► BackupDatabase()()()
Members
Icon | Member | Description
 | BackupDatabase(String, String, String) | Create backup of an Sql Server Database.
 | BackupDatabase(String, String, String, Int32, Boolean) | Create backup of an Sql Server Database.


BackupDatabase Method (aDatabaseName, aConnectionString, aOutputFilename)

BackupDatabase Method (aDatabaseName, aConnectionString, aOutputFilename)
Namespaces ► Devolutions.Utils ► SqlClientUtils ► BackupDatabase(String, String, String)
Create backup of an Sql Server Database.
Declaration Syntax
C# Visual Basic Visual C++
public static bool BackupDatabase(
    string aDatabaseName,
    string aConnectionString,
    string aOutputFilename
)
Public Shared Function BackupDatabase ( _
    aDatabaseName As String, _
    aConnectionString As String, _
    aOutputFilename As String _
) As Boolean
public:
static bool BackupDatabase(
    String^ aDatabaseName,
    String^ aConnectionString,
    String^ aOutputFilename
)
Parameters
aDatabaseName (String)
aConnectionString (String)
aOutputFilename (String)
Return Value


BackupDatabase Method (aDatabaseName, aConnectionString, aOutputFilename, aCommandTimeout, aIsKillConnections)

BackupDatabase Method (aDatabaseName, aConnectionString, aOutputFilename, aCommandTimeout, aIsKillConnections)
Namespaces ► Devolutions.Utils ► SqlClientUtils ► BackupDatabase(String, String, String, Int32, Boolean)
Create backup of an Sql Server Database.
Declaration Syntax
C# Visual Basic Visual C++
public static bool BackupDatabase(
    string aDatabaseName,
    string aConnectionString,
    string aOutputFilename,
    int aCommandTimeout,
    bool aIsKillConnections
)
Public Shared Function BackupDatabase ( _
    aDatabaseName As String, _
    aConnectionString As String, _
    aOutputFilename As String, _
    aCommandTimeout As Integer, _
    aIsKillConnections As Boolean _
) As Boolean
public:
static bool BackupDatabase(
    String^ aDatabaseName,
    String^ aConnectionString,
    String^ aOutputFilename,
    int aCommandTimeout,
    bool aIsKillConnections
)
Parameters
aDatabaseName (String)
aConnectionString (String)
aOutputFilename (String)
aCommandTimeout (Int32)
aIsKillConnections (Boolean)
Return Value


ChangeConnectionStringDatabase Method (aConnectionString, aDatabaseName)

ChangeConnectionStringDatabase Method (aConnectionString, aDatabaseName)
Namespaces ► Devolutions.Utils ► SqlClientUtils ► ChangeConnectionStringDatabase(String, String)
Change the database name from an existing connection string.
Declaration Syntax
C# Visual Basic Visual C++
public static string ChangeConnectionStringDatabase(
    string aConnectionString,
    string aDatabaseName
)
Public Shared Function ChangeConnectionStringDatabase ( _
    aConnectionString As String, _
    aDatabaseName As String _
) As String
public:
static String^ ChangeConnectionStringDatabase(
    String^ aConnectionString,
    String^ aDatabaseName
)
Parameters
aConnectionString (String)
aDatabaseName (String)
Return Value


ChangeConnectionStringDatabaseToMaster Method (aConnectionString)

ChangeConnectionStringDatabaseToMaster Method (aConnectionString)
Namespaces ► Devolutions.Utils ► SqlClientUtils ► ChangeConnectionStringDatabaseToMaster(String)
Change the database name from an existing connection string to master.
Declaration Syntax
C# Visual Basic Visual C++
public static string ChangeConnectionStringDatabaseToMaster(
    string aConnectionString
)
Public Shared Function ChangeConnectionStringDatabaseToMaster ( _
    aConnectionString As String _
) As String
public:
static String^ ChangeConnectionStringDatabaseToMaster(
    String^ aConnectionString
)
Parameters
aConnectionString (String)
Return Value


CreateDatabase Method (aDatabaseName, aConnectionString)

CreateDatabase Method (aDatabaseName, aConnectionString)
Namespaces ► Devolutions.Utils ► SqlClientUtils ► CreateDatabase(String, String)
Create a new empty SqlServer database.
Declaration Syntax
C# Visual Basic Visual C++
public static void CreateDatabase(
    string aDatabaseName,
    string aConnectionString
)
Public Shared Sub CreateDatabase ( _
    aDatabaseName As String, _
    aConnectionString As String _
)
public:
static void CreateDatabase(
    String^ aDatabaseName,
    String^ aConnectionString
)
Parameters
aDatabaseName (String)
aConnectionString (String)


CreateSqlCommand Method (aSql)

CreateSqlCommand Method (aSql)
Namespaces ► Devolutions.Utils ► SqlClientUtils ► CreateSqlCommand(String)
Create and return a SqlCommand with the default Connection string
Declaration Syntax
C# Visual Basic Visual C++
public static SqlCommand CreateSqlCommand(
    string aSql
)
Public Shared Function CreateSqlCommand ( _
    aSql As String _
) As SqlCommand
public:
static SqlCommand^ CreateSqlCommand(
    String^ aSql
)
Parameters
aSql (String)
Return Value


CreateSqlConnection Method

CreateSqlConnection Method
Namespaces ► Devolutions.Utils ► SqlClientUtils ► CreateSqlConnection()()()
Create an Sql Server connection with the default connection string.
Declaration Syntax
C# Visual Basic Visual C++
public static SqlConnection CreateSqlConnection()
Public Shared Function CreateSqlConnection As SqlConnection
public:
static SqlConnection^ CreateSqlConnection()
Return Value


DatabaseExists Method (aDatabaseName, aConnectionString)

DatabaseExists Method (aDatabaseName, aConnectionString)
Namespaces ► Devolutions.Utils ► SqlClientUtils ► DatabaseExists(String, String)
Check if a database exists.
Declaration Syntax
C# Visual Basic Visual C++
public static bool DatabaseExists(
    string aDatabaseName,
    string aConnectionString
)
Public Shared Function DatabaseExists ( _
    aDatabaseName As String, _
    aConnectionString As String _
) As Boolean
public:
static bool DatabaseExists(
    String^ aDatabaseName,
    String^ aConnectionString
)
Parameters
aDatabaseName (String)
aConnectionString (String)
Return Value


DefaultConnectionString Property

DefaultConnectionString Property
Namespaces ► Devolutions.Utils ► SqlClientUtils ► DefaultConnectionString
Default connection string used.
Declaration Syntax
C# Visual Basic Visual C++
public static string DefaultConnectionString { get; set; }
Public Shared Property DefaultConnectionString As String
public:
static property String^ DefaultConnectionString {
    String^ get ();
    void set (String^ value);
}


DefaultSqlCommandTimeout Property

DefaultSqlCommandTimeout Property
Namespaces ► Devolutions.Utils ► SqlClientUtils ► DefaultSqlCommandTimeout
Default SQl command timeout used by SqlClientUtils. 30 seconds by default.
Declaration Syntax
C# Visual Basic Visual C++
public static int DefaultSqlCommandTimeout { get; set; }
Public Shared Property DefaultSqlCommandTimeout As Integer
public:
static property int DefaultSqlCommandTimeout {
    int get ();
    void set (int value);
}


DropDatabase Method (aDatabaseName, aConnectionString)

DropDatabase Method (aDatabaseName, aConnectionString)
Namespaces ► Devolutions.Utils ► SqlClientUtils ► DropDatabase(String, String)
Drop an existing Sql Server database.
Declaration Syntax
C# Visual Basic Visual C++
public static void DropDatabase(
    string aDatabaseName,
    string aConnectionString
)
Public Shared Sub DropDatabase ( _
    aDatabaseName As String, _
    aConnectionString As String _
)
public:
static void DropDatabase(
    String^ aDatabaseName,
    String^ aConnectionString
)
Parameters
aDatabaseName (String)
aConnectionString (String)


GetDatabaseFileInformation Method (aDatabaseName, aConnectionString)

GetDatabaseFileInformation Method (aDatabaseName, aConnectionString)
Namespaces ► Devolutions.Utils ► SqlClientUtils ► GetDatabaseFileInformation(String, String)
Return the Database file information (Name, FileName and FileSize).
Declaration Syntax
C# Visual Basic Visual C++
public static DataSet GetDatabaseFileInformation(
    string aDatabaseName,
    string aConnectionString
)
Public Shared Function GetDatabaseFileInformation ( _
    aDatabaseName As String, _
    aConnectionString As String _
) As DataSet
public:
static DataSet^ GetDatabaseFileInformation(
    String^ aDatabaseName,
    String^ aConnectionString
)
Parameters
aDatabaseName (String)
aConnectionString (String)
Return Value


GetDataSet Method

GetDataSet Method
Namespaces ► Devolutions.Utils ► SqlClientUtils ► GetDataSet()()()
Members
Icon | Member | Description
 | GetDataSet(SqlCommand, Boolean, String) | Fill a dataset.
 | GetDataSet(String, array<SqlParameter>[]()[], Boolean, String) | Fill a dataset.
 | GetDataSet(String, String) | Fill a dataset.


GetDataSet Method (aSqlCommand, aSchemaOnly, aConnectionString)

GetDataSet Method (aSqlCommand, aSchemaOnly, aConnectionString)
Namespaces ► Devolutions.Utils ► SqlClientUtils ► GetDataSet(SqlCommand, Boolean, String)
Fill a dataset.
Declaration Syntax
C# Visual Basic Visual C++
public static DataSet GetDataSet(
    SqlCommand aSqlCommand,
    bool aSchemaOnly,
    string aConnectionString
)
Public Shared Function GetDataSet ( _
    aSqlCommand As SqlCommand, _
    aSchemaOnly As Boolean, _
    aConnectionString As String _
) As DataSet
public:
static DataSet^ GetDataSet(
    SqlCommand^ aSqlCommand,
    bool aSchemaOnly,
    String^ aConnectionString
)
Parameters
aSqlCommand (SqlCommand)
aSchemaOnly (Boolean)
aConnectionString (String)
Return Value


GetDataSet Method (aSql, aConnectionString)

GetDataSet Method (aSql, aConnectionString)
Namespaces ► Devolutions.Utils ► SqlClientUtils ► GetDataSet(String, String)
Fill a dataset.
Declaration Syntax
C# Visual Basic Visual C++
public static DataSet GetDataSet(
    string aSql,
    string aConnectionString
)
Public Shared Function GetDataSet ( _
    aSql As String, _
    aConnectionString As String _
) As DataSet
public:
static DataSet^ GetDataSet(
    String^ aSql,
    String^ aConnectionString
)
Parameters
aSql (String)
aConnectionString (String)
Return Value


GetDataSet Method (aSql, aSqlParameters, aMetaDataOnly, aConnectionString)

GetDataSet Method (aSql, aSqlParameters, aMetaDataOnly, aConnectionString)
Namespaces ► Devolutions.Utils ► SqlClientUtils ► GetDataSet(String, array<SqlParameter>[]()[], Boolean, String)
Fill a dataset.
Declaration Syntax
C# Visual Basic Visual C++
public static DataSet GetDataSet(
    string aSql,
    SqlParameter[] aSqlParameters,
    bool aMetaDataOnly,
    string aConnectionString
)
Public Shared Function GetDataSet ( _
    aSql As String, _
    aSqlParameters As SqlParameter(), _
    aMetaDataOnly As Boolean, _
    aConnectionString As String _
) As DataSet
public:
static DataSet^ GetDataSet(
    String^ aSql,
    array<SqlParameter^>^ aSqlParameters,
    bool aMetaDataOnly,
    String^ aConnectionString
)
Parameters
aSql (String)
aSqlParameters (array< SqlParameter >[]()[])
aMetaDataOnly (Boolean)
aConnectionString (String)
Return Value


GetTableFieldNames Method (aTableName, aConnectionString)

GetTableFieldNames Method (aTableName, aConnectionString)
Namespaces ► Devolutions.Utils ► SqlClientUtils ► GetTableFieldNames(String, String)
Return the field name for a specific table.
Declaration Syntax
C# Visual Basic Visual C++
public static DataSet GetTableFieldNames(
    string aTableName,
    string aConnectionString
)
Public Shared Function GetTableFieldNames ( _
    aTableName As String, _
    aConnectionString As String _
) As DataSet
public:
static DataSet^ GetTableFieldNames(
    String^ aTableName,
    String^ aConnectionString
)
Parameters
aTableName (String)
aConnectionString (String)
Return Value


GetTableNames Method (aConnectionString)

GetTableNames Method (aConnectionString)
Namespaces ► Devolutions.Utils ► SqlClientUtils ► GetTableNames(String)
Return all the table names of a database.
Declaration Syntax
C# Visual Basic Visual C++
public static DataSet GetTableNames(
    string aConnectionString
)
Public Shared Function GetTableNames ( _
    aConnectionString As String _
) As DataSet
public:
static DataSet^ GetTableNames(
    String^ aConnectionString
)
Parameters
aConnectionString (String)
Return Value


GetTableRelations Method (aTableName, aConnectionString)

GetTableRelations Method (aTableName, aConnectionString)
Namespaces ► Devolutions.Utils ► SqlClientUtils ► GetTableRelations(String, String)
Return all the relations contained in a table.
Declaration Syntax
C# Visual Basic Visual C++
public static DataSet GetTableRelations(
    string aTableName,
    string aConnectionString
)
Public Shared Function GetTableRelations ( _
    aTableName As String, _
    aConnectionString As String _
) As DataSet
public:
static DataSet^ GetTableRelations(
    String^ aTableName,
    String^ aConnectionString
)
Parameters
aTableName (String)
aConnectionString (String)
Return Value


GetViewNames Method (aConnectionString)

GetViewNames Method (aConnectionString)
Namespaces ► Devolutions.Utils ► SqlClientUtils ► GetViewNames(String)
Return all the views of a database.
Declaration Syntax
C# Visual Basic Visual C++
public static DataSet GetViewNames(
    string aConnectionString
)
Public Shared Function GetViewNames ( _
    aConnectionString As String _
) As DataSet
public:
static DataSet^ GetViewNames(
    String^ aConnectionString
)
Parameters
aConnectionString (String)
Return Value


KillDatabaseConnections Method (aDatabaseName, aConnectionString)

KillDatabaseConnections Method (aDatabaseName, aConnectionString)
Namespaces ► Devolutions.Utils ► SqlClientUtils ► KillDatabaseConnections(String, String)
Close all the connection for a database. Be carefull when using this method, it might causes problems if an external process uses the connection.
Declaration Syntax
C# Visual Basic Visual C++
public static bool KillDatabaseConnections(
    string aDatabaseName,
    string aConnectionString
)
Public Shared Function KillDatabaseConnections ( _
    aDatabaseName As String, _
    aConnectionString As String _
) As Boolean
public:
static bool KillDatabaseConnections(
    String^ aDatabaseName,
    String^ aConnectionString
)
Parameters
aDatabaseName (String)
aConnectionString (String)


MoveDatabase Method (aDatabaseName, aNewFileDirectory, aConnectionString)

MoveDatabase Method (aDatabaseName, aNewFileDirectory, aConnectionString)
Namespaces ► Devolutions.Utils ► SqlClientUtils ► MoveDatabase(String, String, String)
Move physically the database from a folder to an other.
Declaration Syntax
C# Visual Basic Visual C++
public static string MoveDatabase(
    string aDatabaseName,
    string aNewFileDirectory,
    string aConnectionString
)
Public Shared Function MoveDatabase ( _
    aDatabaseName As String, _
    aNewFileDirectory As String, _
    aConnectionString As String _
) As String
public:
static String^ MoveDatabase(
    String^ aDatabaseName,
    String^ aNewFileDirectory,
    String^ aConnectionString
)
Parameters
aDatabaseName (String)
aNewFileDirectory (String)
aConnectionString (String)
Return Value
String.Empty if everything worked fine, Otherwise the error message is returned


RestoreDatabase Method

RestoreDatabase Method
Namespaces ► Devolutions.Utils ► SqlClientUtils ► RestoreDatabase()()()
Members
Icon | Member | Description
 | RestoreDatabase(String, String, String) | Restore a backup file.
 | RestoreDatabase(String, String, String, Int32) | Restore a backup file.


RestoreDatabase Method (aDatabaseName, aConnectionString, aInputFilename)

RestoreDatabase Method (aDatabaseName, aConnectionString, aInputFilename)
Namespaces ► Devolutions.Utils ► SqlClientUtils ► RestoreDatabase(String, String, String)
Restore a backup file.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RestoreDatabase(
    string aDatabaseName,
    string aConnectionString,
    string aInputFilename
)
Public Shared Function RestoreDatabase ( _
    aDatabaseName As String, _
    aConnectionString As String, _
    aInputFilename As String _
) As Boolean
public:
static bool RestoreDatabase(
    String^ aDatabaseName,
    String^ aConnectionString,
    String^ aInputFilename
)
Parameters
aDatabaseName (String)
aConnectionString (String)
aInputFilename (String)
Return Value


RestoreDatabase Method (aDatabaseName, aConnectionString, aInputFilename, aCommandTimeout)

RestoreDatabase Method (aDatabaseName, aConnectionString, aInputFilename, aCommandTimeout)
Namespaces ► Devolutions.Utils ► SqlClientUtils ► RestoreDatabase(String, String, String, Int32)
Restore a backup file.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RestoreDatabase(
    string aDatabaseName,
    string aConnectionString,
    string aInputFilename,
    int aCommandTimeout
)
Public Shared Function RestoreDatabase ( _
    aDatabaseName As String, _
    aConnectionString As String, _
    aInputFilename As String, _
    aCommandTimeout As Integer _
) As Boolean
public:
static bool RestoreDatabase(
    String^ aDatabaseName,
    String^ aConnectionString,
    String^ aInputFilename,
    int aCommandTimeout
)
Parameters
aDatabaseName (String)
aConnectionString (String)
aInputFilename (String)
aCommandTimeout (Int32)
Return Value


StreamUtils Class

StreamUtils Class
Namespaces ► Devolutions.Utils ► StreamUtils
This class contains the stream utility functions.
Declaration Syntax
C# Visual Basic Visual C++
public static class StreamUtils
Public NotInheritable Class StreamUtils
public ref class StreamUtils abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Copy(Stream, Stream) | Copy a stream to an other
 | GetCompressedDeflateGZipStream(Stream) | Create a compressed stream (Deflate)
 | GetCompressedGZipStream(Stream) | Create a compressed stream (GZip)
 | GetUncompressedDeflateStream(Stream) | Create a decompressed stream (Deflate)
 | GetUncompressedGZipStream(Stream) | Create a decompressed stream (GZip)
Inheritance Hierarchy
Object
StreamUtils


Copy Method (aFrom, aTo)

Copy Method (aFrom, aTo)
Namespaces ► Devolutions.Utils ► StreamUtils ► Copy(Stream, Stream)
Copy a stream to an other
Declaration Syntax
C# Visual Basic Visual C++
public static void Copy(
    Stream aFrom,
    Stream aTo
)
Public Shared Sub Copy ( _
    aFrom As Stream, _
    aTo As Stream _
)
public:
static void Copy(
    Stream^ aFrom,
    Stream^ aTo
)
Parameters
aFrom (Stream)
/Source
aTo (Stream)
Destination


GetCompressedDeflateGZipStream Method (aInputStream)

GetCompressedDeflateGZipStream Method (aInputStream)
Namespaces ► Devolutions.Utils ► StreamUtils ► GetCompressedDeflateGZipStream(Stream)
Create a compressed stream (Deflate)
Declaration Syntax
C# Visual Basic Visual C++
public static Stream GetCompressedDeflateGZipStream(
    Stream aInputStream
)
Public Shared Function GetCompressedDeflateGZipStream ( _
    aInputStream As Stream _
) As Stream
public:
static Stream^ GetCompressedDeflateGZipStream(
    Stream^ aInputStream
)
Parameters
aInputStream (Stream)
Source
Return Value
A new compressed stream


GetCompressedGZipStream Method (aInputStream)

GetCompressedGZipStream Method (aInputStream)
Namespaces ► Devolutions.Utils ► StreamUtils ► GetCompressedGZipStream(Stream)
Create a compressed stream (GZip)
Declaration Syntax
C# Visual Basic Visual C++
public static Stream GetCompressedGZipStream(
    Stream aInputStream
)
Public Shared Function GetCompressedGZipStream ( _
    aInputStream As Stream _
) As Stream
public:
static Stream^ GetCompressedGZipStream(
    Stream^ aInputStream
)
Parameters
aInputStream (Stream)
Source
Return Value
A new compressed stream


GetUncompressedDeflateStream Method (aInputStream)

GetUncompressedDeflateStream Method (aInputStream)
Namespaces ► Devolutions.Utils ► StreamUtils ► GetUncompressedDeflateStream(Stream)
Create a decompressed stream (Deflate)
Declaration Syntax
C# Visual Basic Visual C++
public static Stream GetUncompressedDeflateStream(
    Stream aInputStream
)
Public Shared Function GetUncompressedDeflateStream ( _
    aInputStream As Stream _
) As Stream
public:
static Stream^ GetUncompressedDeflateStream(
    Stream^ aInputStream
)
Parameters
aInputStream (Stream)
Source
Return Value
A new decompressed stream


GetUncompressedGZipStream Method (aInputStream)

GetUncompressedGZipStream Method (aInputStream)
Namespaces ► Devolutions.Utils ► StreamUtils ► GetUncompressedGZipStream(Stream)
Create a decompressed stream (GZip)
Declaration Syntax
C# Visual Basic Visual C++
public static Stream GetUncompressedGZipStream(
    Stream aInputStream
)
Public Shared Function GetUncompressedGZipStream ( _
    aInputStream As Stream _
) As Stream
public:
static Stream^ GetUncompressedGZipStream(
    Stream^ aInputStream
)
Parameters
aInputStream (Stream)
Source
Return Value
A new decompressed stream


StringUtils Class

StringUtils Class
Namespaces ► Devolutions.Utils ► StringUtils
This class contains the string utility functions.
Declaration Syntax
C# Visual Basic Visual C++
public static class StringUtils
Public NotInheritable Class StringUtils
public ref class StringUtils abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AreCaseInsensitiveEquals(String, String) | Compare two strings with invariant culture and not case sensitive
 | Concat(Array, String) | Concat an array to a string with a space
 | FormatByteToString(Int64) | Transform the size in byte to a string: bytes, kb, mb or gb
 | FormatTimeSpan(TimeSpan) | Return a Time Span formated
 | IsGuid(String) | Check if the string is a Guid. Null or empty string are not Guid.
 | IsInList(array<String>[]()[], String) | Indicate if the value is in the list
 | QuoteDBString(String) | Add a single quote to a string like it's needed for an SqlServer string.
 | QuoteString(String, String) | Add a quote at the begining and the end of string.
 | QuoteString(String) | Add a quote at the begining and the end of string.
 | ToGuid(String) | Return a guid value from a string or Guid.Empty if the string is null or empty.
 | ToPascalCase(String) | Convert a string in pascal case (also called title case) Ex: hello world -> Hello World
 | ToSentenceCase(String) | Convert a string in sentense case Ex: hello world -> Hello world
 | ToString(array<String>[]()[], String) | Create a string separated with suffix from a string array.
 | ToString(array<String>[]()[]) | Create a string separated with CR LF from a string array.
Inheritance Hierarchy
Object
StringUtils


AreCaseInsensitiveEquals Method (aValue1, aValue2)

AreCaseInsensitiveEquals Method (aValue1, aValue2)
Namespaces ► Devolutions.Utils ► StringUtils ► AreCaseInsensitiveEquals(String, String)
Compare two strings with invariant culture and not case sensitive
Declaration Syntax
C# Visual Basic Visual C++
public static bool AreCaseInsensitiveEquals(
    string aValue1,
    string aValue2
)
Public Shared Function AreCaseInsensitiveEquals ( _
    aValue1 As String, _
    aValue2 As String _
) As Boolean
public:
static bool AreCaseInsensitiveEquals(
    String^ aValue1,
    String^ aValue2
)
Parameters
aValue1 (String)
aValue2 (String)
Return Value


Concat Method (aStrings, aSpacer)

Concat Method (aStrings, aSpacer)
Namespaces ► Devolutions.Utils ► StringUtils ► Concat(Array, String)
Concat an array to a string with a space
Declaration Syntax
C# Visual Basic Visual C++
public static string Concat(
    Array aStrings,
    string aSpacer
)
Public Shared Function Concat ( _
    aStrings As Array, _
    aSpacer As String _
) As String
public:
static String^ Concat(
    Array^ aStrings,
    String^ aSpacer
)
Parameters
aStrings (Array)
aSpacer (String)
Return Value


FormatByteToString Method (aSize)

FormatByteToString Method (aSize)
Namespaces ► Devolutions.Utils ► StringUtils ► FormatByteToString(Int64)
Transform the size in byte to a string: bytes, kb, mb or gb
Declaration Syntax
C# Visual Basic Visual C++
public static string FormatByteToString(
    long aSize
)
Public Shared Function FormatByteToString ( _
    aSize As Long _
) As String
public:
static String^ FormatByteToString(
    long long aSize
)
Parameters
aSize (Int64)
Return Value


FormatTimeSpan Method (aTimeSpan)

FormatTimeSpan Method (aTimeSpan)
Namespaces ► Devolutions.Utils ► StringUtils ► FormatTimeSpan(TimeSpan)
Return a Time Span formated
Declaration Syntax
C# Visual Basic Visual C++
public static string FormatTimeSpan(
    TimeSpan aTimeSpan
)
Public Shared Function FormatTimeSpan ( _
    aTimeSpan As TimeSpan _
) As String
public:
static String^ FormatTimeSpan(
    TimeSpan aTimeSpan
)
Parameters
aTimeSpan (TimeSpan)
Return Value


IsGuid Method (aValue)

IsGuid Method (aValue)
Namespaces ► Devolutions.Utils ► StringUtils ► IsGuid(String)
Check if the string is a Guid. Null or empty string are not Guid.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsGuid(
    string aValue
)
Public Shared Function IsGuid ( _
    aValue As String _
) As Boolean
public:
static bool IsGuid(
    String^ aValue
)
Parameters
aValue (String)
Return Value


IsInList Method (aList, aValue)

IsInList Method (aList, aValue)
Namespaces ► Devolutions.Utils ► StringUtils ► IsInList(array<String>[]()[], String)
Indicate if the value is in the list
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsInList(
    string[] aList,
    string aValue
)
Public Shared Function IsInList ( _
    aList As String(), _
    aValue As String _
) As Boolean
public:
static bool IsInList(
    array<String^>^ aList,
    String^ aValue
)
Parameters
aList (array< String >[]()[])
aValue (String)
Return Value


QuoteDBString Method (aStr)

QuoteDBString Method (aStr)
Namespaces ► Devolutions.Utils ► StringUtils ► QuoteDBString(String)
Add a single quote to a string like it's needed for an SqlServer string.
Declaration Syntax
C# Visual Basic Visual C++
public static string QuoteDBString(
    string aStr
)
Public Shared Function QuoteDBString ( _
    aStr As String _
) As String
public:
static String^ QuoteDBString(
    String^ aStr
)
Parameters
aStr (String)
Return Value


QuoteString Method

QuoteString Method
Namespaces ► Devolutions.Utils ► StringUtils ► QuoteString()()()
Members
Icon | Member | Description
 | QuoteString(String, String) | Add a quote at the begining and the end of string.
 | QuoteString(String) | Add a quote at the begining and the end of string.


QuoteString Method (aStr)

QuoteString Method (aStr)
Namespaces ► Devolutions.Utils ► StringUtils ► QuoteString(String)
Add a quote at the begining and the end of string.
Declaration Syntax
C# Visual Basic Visual C++
public static string QuoteString(
    string aStr
)
Public Shared Function QuoteString ( _
    aStr As String _
) As String
public:
static String^ QuoteString(
    String^ aStr
)
Parameters
aStr (String)
The string to quote.
Return Value


QuoteString Method (aStr, aQuote)

QuoteString Method (aStr, aQuote)
Namespaces ► Devolutions.Utils ► StringUtils ► QuoteString(String, String)
Add a quote at the begining and the end of string.
Declaration Syntax
C# Visual Basic Visual C++
public static string QuoteString(
    string aStr,
    string aQuote
)
Public Shared Function QuoteString ( _
    aStr As String, _
    aQuote As String _
) As String
public:
static String^ QuoteString(
    String^ aStr,
    String^ aQuote
)
Parameters
aStr (String)
The string to quote.
aQuote (String)
The quote could be any string.
Return Value


ToGuid Method (aGuid)

ToGuid Method (aGuid)
Namespaces ► Devolutions.Utils ► StringUtils ► ToGuid(String)
Return a guid value from a string or Guid.Empty if the string is null or empty.
Declaration Syntax
C# Visual Basic Visual C++
public static Guid ToGuid(
    string aGuid
)
Public Shared Function ToGuid ( _
    aGuid As String _
) As Guid
public:
static Guid ToGuid(
    String^ aGuid
)
Parameters
aGuid (String)
Return Value


ToPascalCase Method (aString)

ToPascalCase Method (aString)
Namespaces ► Devolutions.Utils ► StringUtils ► ToPascalCase(String)
Convert a string in pascal case (also called title case) Ex: hello world -> Hello World
Declaration Syntax
C# Visual Basic Visual C++
public static string ToPascalCase(
    string aString
)
Public Shared Function ToPascalCase ( _
    aString As String _
) As String
public:
static String^ ToPascalCase(
    String^ aString
)
Parameters
aString (String)
Return Value


ToSentenceCase Method (aString)

ToSentenceCase Method (aString)
Namespaces ► Devolutions.Utils ► StringUtils ► ToSentenceCase(String)
Convert a string in sentense case Ex: hello world -> Hello world
Declaration Syntax
C# Visual Basic Visual C++
public static string ToSentenceCase(
    string aString
)
Public Shared Function ToSentenceCase ( _
    aString As String _
) As String
public:
static String^ ToSentenceCase(
    String^ aString
)
Parameters
aString (String)
Return Value


ToString Method

ToString Method
Namespaces ► Devolutions.Utils ► StringUtils ► ToString()()()
Members
Icon | Member | Description
 | ToString(array<String>[]()[], String) | Create a string separated with suffix from a string array.
 | ToString(array<String>[]()[]) | Create a string separated with CR LF from a string array.


ToString Method (aStrings)

ToString Method (aStrings)
Namespaces ► Devolutions.Utils ► StringUtils ► ToString(array<String>[]()[])
Create a string separated with CR LF from a string array.
Declaration Syntax
C# Visual Basic Visual C++
public static string ToString(
    string[] aStrings
)
Public Shared Function ToString ( _
    aStrings As String() _
) As String
public:
static String^ ToString(
    array<String^>^ aStrings
)
Parameters
aStrings (array< String >[]()[])
Return Value


ToString Method (aStrings, aSuffix)

ToString Method (aStrings, aSuffix)
Namespaces ► Devolutions.Utils ► StringUtils ► ToString(array<String>[]()[], String)
Create a string separated with suffix from a string array.
Declaration Syntax
C# Visual Basic Visual C++
public static string ToString(
    string[] aStrings,
    string aSuffix
)
Public Shared Function ToString ( _
    aStrings As String(), _
    aSuffix As String _
) As String
public:
static String^ ToString(
    array<String^>^ aStrings,
    String^ aSuffix
)
Parameters
aStrings (array< String >[]()[])
aSuffix (String)
Return Value


SystemUtils Class

SystemUtils Class
Namespaces ► Devolutions.Utils ► SystemUtils
This class contains System utilities related to .Net or to the operating system.
Declaration Syntax
C# Visual Basic Visual C++
public static class SystemUtils
Public NotInheritable Class SystemUtils
public ref class SystemUtils abstract sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AllUsersAdministrativeToolsFolder | Return the All Yser Administrative Tools folder.
 | AllUsersDesktopFolder | Return the All User Desktop folder.
 | AllUsersProgramsFolder | Return the All User Program folder.
 | AllUsersStartMenu | Return the All User Start Menu folder.
 | ApplicationIsInstalled(String) | Use the WMI to check if an application is installed.
 | ApplicationIsRunning(String) | Verify if an application is running.
 | CPUId | Return the CPU Id with WMI.
 | CurrentUserAdministrativeToolsFolder | Return the Current User Administrative Tools folder.
 | CurrentUserProgramsFolder | Return the Current User Program folder.
 | DotNetRunTimeVersion | Return the current .Net Framework runtime version.
 | FlushMemory(Boolean) | Reduce the memory usage with or without a Garbage Collect.
 | GetExternalIPAddress()()() | Return the external IP address for the current machine
 | GetInstalledApplications()()() | Return the installed application names and version in parentheses
 | GetVolumeSerial(String) | Retreive the drive serial number.
 | InstalledFrameworkVersions | Return all the Installed .Net Framework version.
 | IsAspNetServer | Indicate if the application is an ASP.Net application.
 | IsConsoleApplication | Indicate if the application is running in console mode.
 | IsMediaCenter | Indicate if the current machine is a Media Center
 | IsOffline | Indicate if the current computer is connected to the Internet.
 | IsRunningInTerminalServices | Indicate if the application is running in a Terminal Services mode.
 | IsTabletPC | Indicate if the current machine is a TabletPC
 | IsWindowsVistaOrGreater | Vertify that the current Operating System is Vista or better.
 | IsWindowsXPOrGreater | Vertify that the current Operating System is Windows XP or better.
 | MACAddress | Return the MAC address with WMI from the first network card.
 | TerminateProcess(String) | Terminate all instance of a process.
 | TotalPhysicalMemory | Return the total physical memory on the current machine by using WMI.
Inheritance Hierarchy
Object
SystemUtils


AllUsersAdministrativeToolsFolder Property

AllUsersAdministrativeToolsFolder Property
Namespaces ► Devolutions.Utils ► SystemUtils ► AllUsersAdministrativeToolsFolder
Return the All Yser Administrative Tools folder.
Declaration Syntax
C# Visual Basic Visual C++
public static string AllUsersAdministrativeToolsFolder { get; }
Public Shared ReadOnly Property AllUsersAdministrativeToolsFolder As String
public:
static property String^ AllUsersAdministrativeToolsFolder {
    String^ get ();
}


AllUsersDesktopFolder Property

AllUsersDesktopFolder Property
Namespaces ► Devolutions.Utils ► SystemUtils ► AllUsersDesktopFolder
Return the All User Desktop folder.
Declaration Syntax
C# Visual Basic Visual C++
public static string AllUsersDesktopFolder { get; }
Public Shared ReadOnly Property AllUsersDesktopFolder As String
public:
static property String^ AllUsersDesktopFolder {
    String^ get ();
}


AllUsersProgramsFolder Property

AllUsersProgramsFolder Property
Namespaces ► Devolutions.Utils ► SystemUtils ► AllUsersProgramsFolder
Return the All User Program folder.
Declaration Syntax
C# Visual Basic Visual C++
public static string AllUsersProgramsFolder { get; }
Public Shared ReadOnly Property AllUsersProgramsFolder As String
public:
static property String^ AllUsersProgramsFolder {
    String^ get ();
}


AllUsersStartMenu Property

AllUsersStartMenu Property
Namespaces ► Devolutions.Utils ► SystemUtils ► AllUsersStartMenu
Return the All User Start Menu folder.
Declaration Syntax
C# Visual Basic Visual C++
public static string AllUsersStartMenu { get; }
Public Shared ReadOnly Property AllUsersStartMenu As String
public:
static property String^ AllUsersStartMenu {
    String^ get ();
}


ApplicationIsInstalled Method (aName)

ApplicationIsInstalled Method (aName)
Namespaces ► Devolutions.Utils ► SystemUtils ► ApplicationIsInstalled(String)
Use the WMI to check if an application is installed.
Declaration Syntax
C# Visual Basic Visual C++
public static bool ApplicationIsInstalled(
    string aName
)
Public Shared Function ApplicationIsInstalled ( _
    aName As String _
) As Boolean
public:
static bool ApplicationIsInstalled(
    String^ aName
)
Parameters
aName (String)
Return Value


ApplicationIsRunning Method (aName)

ApplicationIsRunning Method (aName)
Namespaces ► Devolutions.Utils ► SystemUtils ► ApplicationIsRunning(String)
Verify if an application is running.
Declaration Syntax
C# Visual Basic Visual C++
public static bool ApplicationIsRunning(
    string aName
)
Public Shared Function ApplicationIsRunning ( _
    aName As String _
) As Boolean
public:
static bool ApplicationIsRunning(
    String^ aName
)
Parameters
aName (String)
Return Value


CPUId Property

CPUId Property
Namespaces ► Devolutions.Utils ► SystemUtils ► CPUId
Return the CPU Id with WMI.
Declaration Syntax
C# Visual Basic Visual C++
public static string CPUId { get; }
Public Shared ReadOnly Property CPUId As String
public:
static property String^ CPUId {
    String^ get ();
}


CurrentUserAdministrativeToolsFolder Property

CurrentUserAdministrativeToolsFolder Property
Namespaces ► Devolutions.Utils ► SystemUtils ► CurrentUserAdministrativeToolsFolder
Return the Current User Administrative Tools folder.
Declaration Syntax
C# Visual Basic Visual C++
public static string CurrentUserAdministrativeToolsFolder { get; }
Public Shared ReadOnly Property CurrentUserAdministrativeToolsFolder As String
public:
static property String^ CurrentUserAdministrativeToolsFolder {
    String^ get ();
}


CurrentUserProgramsFolder Property

CurrentUserProgramsFolder Property
Namespaces ► Devolutions.Utils ► SystemUtils ► CurrentUserProgramsFolder
Return the Current User Program folder.
Declaration Syntax
C# Visual Basic Visual C++
public static string CurrentUserProgramsFolder { get; }
Public Shared ReadOnly Property CurrentUserProgramsFolder As String
public:
static property String^ CurrentUserProgramsFolder {
    String^ get ();
}


DotNetRunTimeVersion Property

DotNetRunTimeVersion Property
Namespaces ► Devolutions.Utils ► SystemUtils ► DotNetRunTimeVersion
Return the current .Net Framework runtime version.
Declaration Syntax
C# Visual Basic Visual C++
public static string DotNetRunTimeVersion { get; }
Public Shared ReadOnly Property DotNetRunTimeVersion As String
public:
static property String^ DotNetRunTimeVersion {
    String^ get ();
}
Return Value


FlushMemory Method (aCollectMemory)

FlushMemory Method (aCollectMemory)
Namespaces ► Devolutions.Utils ► SystemUtils ► FlushMemory(Boolean)
Reduce the memory usage with or without a Garbage Collect.
Declaration Syntax
C# Visual Basic Visual C++
public static void FlushMemory(
    bool aCollectMemory
)
Public Shared Sub FlushMemory ( _
    aCollectMemory As Boolean _
)
public:
static void FlushMemory(
    bool aCollectMemory
)
Parameters
aCollectMemory (Boolean)
Return Value


GetExternalIPAddress Method

GetExternalIPAddress Method
Namespaces ► Devolutions.Utils ► SystemUtils ► GetExternalIPAddress()()()
Return the external IP address for the current machine
Declaration Syntax
C# Visual Basic Visual C++
public static IPAddress GetExternalIPAddress()
Public Shared Function GetExternalIPAddress As IPAddress
public:
static IPAddress^ GetExternalIPAddress()
Return Value


GetInstalledApplications Method

GetInstalledApplications Method
Namespaces ► Devolutions.Utils ► SystemUtils ► GetInstalledApplications()()()
Return the installed application names and version in parentheses
Declaration Syntax
C# Visual Basic Visual C++
public static string[] GetInstalledApplications()
Public Shared Function GetInstalledApplications As String()
public:
static array<String^>^ GetInstalledApplications()
Return Value


GetVolumeSerial Method (aDriveLetter)

GetVolumeSerial Method (aDriveLetter)
Namespaces ► Devolutions.Utils ► SystemUtils ► GetVolumeSerial(String)
Retreive the drive serial number.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetVolumeSerial(
    string aDriveLetter
)
Public Shared Function GetVolumeSerial ( _
    aDriveLetter As String _
) As String
public:
static String^ GetVolumeSerial(
    String^ aDriveLetter
)
Parameters
aDriveLetter (String)
Return Value


InstalledFrameworkVersions Property

InstalledFrameworkVersions Property
Namespaces ► Devolutions.Utils ► SystemUtils ► InstalledFrameworkVersions
Return all the Installed .Net Framework version.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] InstalledFrameworkVersions { get; }
Public Shared ReadOnly Property InstalledFrameworkVersions As String()
public:
static property array<String^>^ InstalledFrameworkVersions {
    array<String^>^ get ();
}
Return Value


IsAspNetServer Property

IsAspNetServer Property
Namespaces ► Devolutions.Utils ► SystemUtils ► IsAspNetServer
Indicate if the application is an ASP.Net application.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsAspNetServer { get; }
Public Shared ReadOnly Property IsAspNetServer As Boolean
public:
static property bool IsAspNetServer {
    bool get ();
}
Return Value


IsConsoleApplication Property

IsConsoleApplication Property
Namespaces ► Devolutions.Utils ► SystemUtils ► IsConsoleApplication
Indicate if the application is running in console mode.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsConsoleApplication { get; }
Public Shared ReadOnly Property IsConsoleApplication As Boolean
public:
static property bool IsConsoleApplication {
    bool get ();
}
Return Value


IsMediaCenter Property

IsMediaCenter Property
Namespaces ► Devolutions.Utils ► SystemUtils ► IsMediaCenter
Indicate if the current machine is a Media Center
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsMediaCenter { get; }
Public Shared ReadOnly Property IsMediaCenter As Boolean
public:
static property bool IsMediaCenter {
    bool get ();
}
Return Value


IsOffline Property

IsOffline Property
Namespaces ► Devolutions.Utils ► SystemUtils ► IsOffline
Indicate if the current computer is connected to the Internet.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsOffline { get; }
Public Shared ReadOnly Property IsOffline As Boolean
public:
static property bool IsOffline {
    bool get ();
}
Return Value


IsRunningInTerminalServices Property

IsRunningInTerminalServices Property
Namespaces ► Devolutions.Utils ► SystemUtils ► IsRunningInTerminalServices
Indicate if the application is running in a Terminal Services mode.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsRunningInTerminalServices { get; }
Public Shared ReadOnly Property IsRunningInTerminalServices As Boolean
public:
static property bool IsRunningInTerminalServices {
    bool get ();
}
Return Value


IsTabletPC Property

IsTabletPC Property
Namespaces ► Devolutions.Utils ► SystemUtils ► IsTabletPC
Indicate if the current machine is a TabletPC
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsTabletPC { get; }
Public Shared ReadOnly Property IsTabletPC As Boolean
public:
static property bool IsTabletPC {
    bool get ();
}
Return Value


IsWindowsVistaOrGreater Property

IsWindowsVistaOrGreater Property
Namespaces ► Devolutions.Utils ► SystemUtils ► IsWindowsVistaOrGreater
Vertify that the current Operating System is Vista or better.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsWindowsVistaOrGreater { get; }
Public Shared ReadOnly Property IsWindowsVistaOrGreater As Boolean
public:
static property bool IsWindowsVistaOrGreater {
    bool get ();
}
Return Value


IsWindowsXPOrGreater Property

IsWindowsXPOrGreater Property
Namespaces ► Devolutions.Utils ► SystemUtils ► IsWindowsXPOrGreater
Vertify that the current Operating System is Windows XP or better.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsWindowsXPOrGreater { get; }
Public Shared ReadOnly Property IsWindowsXPOrGreater As Boolean
public:
static property bool IsWindowsXPOrGreater {
    bool get ();
}
Return Value


MACAddress Property

MACAddress Property
Namespaces ► Devolutions.Utils ► SystemUtils ► MACAddress
Return the MAC address with WMI from the first network card.
Declaration Syntax
C# Visual Basic Visual C++
public static string MACAddress { get; }
Public Shared ReadOnly Property MACAddress As String
public:
static property String^ MACAddress {
    String^ get ();
}


TerminateProcess Method (aProcessName)

TerminateProcess Method (aProcessName)
Namespaces ► Devolutions.Utils ► SystemUtils ► TerminateProcess(String)
Terminate all instance of a process.
Declaration Syntax
C# Visual Basic Visual C++
public static bool TerminateProcess(
    string aProcessName
)
Public Shared Function TerminateProcess ( _
    aProcessName As String _
) As Boolean
public:
static bool TerminateProcess(
    String^ aProcessName
)
Parameters
aProcessName (String)
Return Value


TotalPhysicalMemory Property

TotalPhysicalMemory Property
Namespaces ► Devolutions.Utils ► SystemUtils ► TotalPhysicalMemory
Return the total physical memory on the current machine by using WMI.
Declaration Syntax
C# Visual Basic Visual C++
public static long TotalPhysicalMemory { get; }
Public Shared ReadOnly Property TotalPhysicalMemory As Long
public:
static property long long TotalPhysicalMemory {
    long long get ();
}
Return Value


WindowUtils Class

WindowUtils Class
Namespaces ► Devolutions.Utils ► WindowUtils
This class contains some Window Handle utility functions not related directly to WinForms.
Declaration Syntax
C# Visual Basic Visual C++
public static class WindowUtils
Public NotInheritable Class WindowUtils
public ref class WindowUtils abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FlashWindow(IntPtr) | Flash a window in the Windows task bar
 | ForceForegroundWindow(IntPtr) | Open a Window and bring it to front
 | GetWindowIcon(IntPtr) | Return a the Window icon
 | GetWindowText(IntPtr) | Return the Window form title
 | LockWindowUpdate(Form) | Stop the Form from refreshing (repainting)
 | UnlockWindowUpdate()()() | Restart the Form refresh (repainting)
Inheritance Hierarchy
Object
WindowUtils


FlashWindow Method (hWnd)

FlashWindow Method (hWnd)
Namespaces ► Devolutions.Utils ► WindowUtils ► FlashWindow(IntPtr)
Flash a window in the Windows task bar
Declaration Syntax
C# Visual Basic Visual C++
public static void FlashWindow(
    IntPtr hWnd
)
Public Shared Sub FlashWindow ( _
    hWnd As IntPtr _
)
public:
static void FlashWindow(
    IntPtr hWnd
)
Parameters
hWnd (IntPtr)


ForceForegroundWindow Method (hWnd)

ForceForegroundWindow Method (hWnd)
Namespaces ► Devolutions.Utils ► WindowUtils ► ForceForegroundWindow(IntPtr)
Open a Window and bring it to front
Declaration Syntax
C# Visual Basic Visual C++
public static bool ForceForegroundWindow(
    IntPtr hWnd
)
Public Shared Function ForceForegroundWindow ( _
    hWnd As IntPtr _
) As Boolean
public:
static bool ForceForegroundWindow(
    IntPtr hWnd
)
Parameters
hWnd (IntPtr)
Return Value


GetWindowIcon Method (aHandle)

GetWindowIcon Method (aHandle)
Namespaces ► Devolutions.Utils ► WindowUtils ► GetWindowIcon(IntPtr)
Return a the Window icon
Declaration Syntax
C# Visual Basic Visual C++
public static Icon GetWindowIcon(
    IntPtr aHandle
)
Public Shared Function GetWindowIcon ( _
    aHandle As IntPtr _
) As Icon
public:
static Icon^ GetWindowIcon(
    IntPtr aHandle
)
Parameters
aHandle (IntPtr)
Return Value


GetWindowText Method (hWnd)

GetWindowText Method (hWnd)
Namespaces ► Devolutions.Utils ► WindowUtils ► GetWindowText(IntPtr)
Return the Window form title
Declaration Syntax
C# Visual Basic Visual C++
public static string GetWindowText(
    IntPtr hWnd
)
Public Shared Function GetWindowText ( _
    hWnd As IntPtr _
) As String
public:
static String^ GetWindowText(
    IntPtr hWnd
)
Parameters
hWnd (IntPtr)
Return Value


LockWindowUpdate Method (aForm)

LockWindowUpdate Method (aForm)
Namespaces ► Devolutions.Utils ► WindowUtils ► LockWindowUpdate(Form)
Stop the Form from refreshing (repainting)
Declaration Syntax
C# Visual Basic Visual C++
public static void LockWindowUpdate(
    Form aForm
)
Public Shared Sub LockWindowUpdate ( _
    aForm As Form _
)
public:
static void LockWindowUpdate(
    Form^ aForm
)
Parameters
aForm (Form)


UnlockWindowUpdate Method

UnlockWindowUpdate Method
Namespaces ► Devolutions.Utils ► WindowUtils ► UnlockWindowUpdate()()()
Restart the Form refresh (repainting)
Declaration Syntax
C# Visual Basic Visual C++
public static void UnlockWindowUpdate()
Public Shared Sub UnlockWindowUpdate
public:
static void UnlockWindowUpdate()


WinFormsUtils Class

WinFormsUtils Class
Namespaces ► Devolutions.Utils ► WinFormsUtils
This class contains some Windows Form utility functions.
Declaration Syntax
C# Visual Basic Visual C++
public static class WinFormsUtils
Public NotInheritable Class WinFormsUtils
public ref class WinFormsUtils abstract sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ApplicationIcon | Return the application icon
 | CreateDragAndDropStartZone(Int32, Int32) | Create a default start zone for the drag and drop.
 | DataGridViewSelectOnRightClick(Object, MouseEventArgs) | Implement the event for a default select right click behavior used to select an item on right click in a DataGridView.
 | DefaultFormText | Return the default form title used in Devolutions Utils like OpenFile, SaveFile... by default, it return the
 | DropShadowSupported | Indicate if the form drop shadow is supported by the OS
 | ExtractIcon(String, Boolean) | Extract the small or the large icon from a file.
 | FindListViewGroup(ListView, String) | Search a ListView group by with it's name
 | FindListViewItemFromTag(ListView, Object) | Return a ListView item matching where tag is equal to a value
 | FindTreeNodeFromTag(TreeNode, Object) | Find a tree node in a Node.
 | FindTreeNodeFromTag(TreeView, Object) | Find a tree node in a TreeView.
 | MainWindowText | Return the main window text
 | OpenFile(String) | Select a file with a OpenFile dialog
 | OpenFile(String, String) | Select a file with a OpenFile dialog
 | OpenFiles(String, String) | Select a file with a OpenFile dialog
 | SaveFile(String, String) | Select a file with a SaveFile dialog
 | TitleBarHeightDelta | Return the default Delta for the Title Bar size between Windows XP with Theme and Windows 2000. Windows 2000 is the baseline.
 | TreeViewAutoScroll(TreeView, DragEventArgs) | Used to add an autoscroll behavior in a treeview when the user execute a drag and drop.
 | TreeViewContainsNode(TreeNode, TreeNode) | Return true if a treeview node contains an other node.
 | TreeViewDefaultDragOver(Object, DragEventArgs) | Default behavior for a drag over: a - auto open closed nodes - autoscroll
 | TreeViewDefaultItemDrag(Object, ItemDragEventArgs) | Default TreeView Default Item Drag.
Inheritance Hierarchy
Object
WinFormsUtils


ApplicationIcon Property

ApplicationIcon Property
Namespaces ► Devolutions.Utils ► WinFormsUtils ► ApplicationIcon
Return the application icon
Declaration Syntax
C# Visual Basic Visual C++
public static Icon ApplicationIcon { get; }
Public Shared ReadOnly Property ApplicationIcon As Icon
public:
static property Icon^ ApplicationIcon {
    Icon^ get ();
}
Return Value


CreateDragAndDropStartZone Method (x, y)

CreateDragAndDropStartZone Method (x, y)
Namespaces ► Devolutions.Utils ► WinFormsUtils ► CreateDragAndDropStartZone(Int32, Int32)
Create a default start zone for the drag and drop.
Declaration Syntax
C# Visual Basic Visual C++
public static Rectangle CreateDragAndDropStartZone(
    int x,
    int y
)
Public Shared Function CreateDragAndDropStartZone ( _
    x As Integer, _
    y As Integer _
) As Rectangle
public:
static Rectangle CreateDragAndDropStartZone(
    int x,
    int y
)
Parameters
x (Int32)
y (Int32)
Return Value


DataGridViewSelectOnRightClick Method (aSender, e)

DataGridViewSelectOnRightClick Method (aSender, e)
Namespaces ► Devolutions.Utils ► WinFormsUtils ► DataGridViewSelectOnRightClick(Object, MouseEventArgs)
Implement the event for a default select right click behavior used to select an item on right click in a DataGridView.
Declaration Syntax
C# Visual Basic Visual C++
public static void DataGridViewSelectOnRightClick(
    Object aSender,
    MouseEventArgs e
)
Public Shared Sub DataGridViewSelectOnRightClick ( _
    aSender As Object, _
    e As MouseEventArgs _
)
public:
static void DataGridViewSelectOnRightClick(
    Object^ aSender,
    MouseEventArgs^ e
)
Parameters
aSender (Object)
e (MouseEventArgs)


DefaultFormText Property

DefaultFormText Property
Namespaces ► Devolutions.Utils ► WinFormsUtils ► DefaultFormText
Return the default form title used in Devolutions Utils like OpenFile, SaveFile... by default, it return the
Declaration Syntax
C# Visual Basic Visual C++
public static string DefaultFormText { get; set; }
Public Shared Property DefaultFormText As String
public:
static property String^ DefaultFormText {
    String^ get ();
    void set (String^ value);
}


DropShadowSupported Property

DropShadowSupported Property
Namespaces ► Devolutions.Utils ► WinFormsUtils ► DropShadowSupported
Indicate if the form drop shadow is supported by the OS
Declaration Syntax
C# Visual Basic Visual C++
public static bool DropShadowSupported { get; }
Public Shared ReadOnly Property DropShadowSupported As Boolean
public:
static property bool DropShadowSupported {
    bool get ();
}


ExtractIcon Method (aFile, aLarge)

ExtractIcon Method (aFile, aLarge)
Namespaces ► Devolutions.Utils ► WinFormsUtils ► ExtractIcon(String, Boolean)
Extract the small or the large icon from a file.
Declaration Syntax
C# Visual Basic Visual C++
public static Icon ExtractIcon(
    string aFile,
    bool aLarge
)
Public Shared Function ExtractIcon ( _
    aFile As String, _
    aLarge As Boolean _
) As Icon
public:
static Icon^ ExtractIcon(
    String^ aFile,
    bool aLarge
)
Parameters
aFile (String)
aLarge (Boolean)
Return Value


FindListViewGroup Method (aListView, aGroupName)

FindListViewGroup Method (aListView, aGroupName)
Namespaces ► Devolutions.Utils ► WinFormsUtils ► FindListViewGroup(ListView, String)
Search a ListView group by with it's name
Declaration Syntax
C# Visual Basic Visual C++
public static ListViewGroup FindListViewGroup(
    ListView aListView,
    string aGroupName
)
Public Shared Function FindListViewGroup ( _
    aListView As ListView, _
    aGroupName As String _
) As ListViewGroup
public:
static ListViewGroup^ FindListViewGroup(
    ListView^ aListView,
    String^ aGroupName
)
Parameters
aListView (ListView)
aGroupName (String)
Return Value


FindListViewItemFromTag Method (aListView, aTag)

FindListViewItemFromTag Method (aListView, aTag)
Namespaces ► Devolutions.Utils ► WinFormsUtils ► FindListViewItemFromTag(ListView, Object)
Return a ListView item matching where tag is equal to a value
Declaration Syntax
C# Visual Basic Visual C++
public static ListViewItem FindListViewItemFromTag(
    ListView aListView,
    Object aTag
)
Public Shared Function FindListViewItemFromTag ( _
    aListView As ListView, _
    aTag As Object _
) As ListViewItem
public:
static ListViewItem^ FindListViewItemFromTag(
    ListView^ aListView,
    Object^ aTag
)
Parameters
aListView (ListView)
aTag (Object)
Return Value


FindTreeNodeFromTag Method

FindTreeNodeFromTag Method
Namespaces ► Devolutions.Utils ► WinFormsUtils ► FindTreeNodeFromTag()()()
Members
Icon | Member | Description
 | FindTreeNodeFromTag(TreeNode, Object) | Find a tree node in a Node.
 | FindTreeNodeFromTag(TreeView, Object) | Find a tree node in a TreeView.


FindTreeNodeFromTag Method (aNode, aTag)

FindTreeNodeFromTag Method (aNode, aTag)
Namespaces ► Devolutions.Utils ► WinFormsUtils ► FindTreeNodeFromTag(TreeNode, Object)
Find a tree node in a Node.
Declaration Syntax
C# Visual Basic Visual C++
public static TreeNode FindTreeNodeFromTag(
    TreeNode aNode,
    Object aTag
)
Public Shared Function FindTreeNodeFromTag ( _
    aNode As TreeNode, _
    aTag As Object _
) As TreeNode
public:
static TreeNode^ FindTreeNodeFromTag(
    TreeNode^ aNode,
    Object^ aTag
)
Parameters
aNode (TreeNode)
The parent node to search into.
aTag (Object)
The tag to search. Null value are not supported.
Return Value
Return the tree node if it's found or null if not found.


FindTreeNodeFromTag Method (aTreeView, aTag)

FindTreeNodeFromTag Method (aTreeView, aTag)
Namespaces ► Devolutions.Utils ► WinFormsUtils ► FindTreeNodeFromTag(TreeView, Object)
Find a tree node in a TreeView.
Declaration Syntax
C# Visual Basic Visual C++
public static TreeNode FindTreeNodeFromTag(
    TreeView aTreeView,
    Object aTag
)
Public Shared Function FindTreeNodeFromTag ( _
    aTreeView As TreeView, _
    aTag As Object _
) As TreeNode
public:
static TreeNode^ FindTreeNodeFromTag(
    TreeView^ aTreeView,
    Object^ aTag
)
Parameters
aTreeView (TreeView)
The treeview to search in.
aTag (Object)
The tag to search. Null value are not supported.
Return Value
Return the tree node if it's found or null if not found.


MainWindowText Property

MainWindowText Property
Namespaces ► Devolutions.Utils ► WinFormsUtils ► MainWindowText
Return the main window text
Declaration Syntax
C# Visual Basic Visual C++
public static string MainWindowText { get; }
Public Shared ReadOnly Property MainWindowText As String
public:
static property String^ MainWindowText {
    String^ get ();
}
Return Value


OpenFile Method

OpenFile Method
Namespaces ► Devolutions.Utils ► WinFormsUtils ► OpenFile()()()
Members
Icon | Member | Description
 | OpenFile(String) | Select a file with a OpenFile dialog
 | OpenFile(String, String) | Select a file with a OpenFile dialog


OpenFile Method (aFilter)

OpenFile Method (aFilter)
Namespaces ► Devolutions.Utils ► WinFormsUtils ► OpenFile(String)
Select a file with a OpenFile dialog
Declaration Syntax
C# Visual Basic Visual C++
public static string OpenFile(
    string aFilter
)
Public Shared Function OpenFile ( _
    aFilter As String _
) As String
public:
static String^ OpenFile(
    String^ aFilter
)
Parameters
aFilter (String)
Return Value


OpenFile Method (aFilter, aDefaultFileName)

OpenFile Method (aFilter, aDefaultFileName)
Namespaces ► Devolutions.Utils ► WinFormsUtils ► OpenFile(String, String)
Select a file with a OpenFile dialog
Declaration Syntax
C# Visual Basic Visual C++
public static string OpenFile(
    string aFilter,
    string aDefaultFileName
)
Public Shared Function OpenFile ( _
    aFilter As String, _
    aDefaultFileName As String _
) As String
public:
static String^ OpenFile(
    String^ aFilter,
    String^ aDefaultFileName
)
Parameters
aFilter (String)
aDefaultFileName (String)
Return Value


OpenFiles Method (aFilter, aDefaultFileName)

OpenFiles Method (aFilter, aDefaultFileName)
Namespaces ► Devolutions.Utils ► WinFormsUtils ► OpenFiles(String, String)
Select a file with a OpenFile dialog
Declaration Syntax
C# Visual Basic Visual C++
public static string[] OpenFiles(
    string aFilter,
    string aDefaultFileName
)
Public Shared Function OpenFiles ( _
    aFilter As String, _
    aDefaultFileName As String _
) As String()
public:
static array<String^>^ OpenFiles(
    String^ aFilter,
    String^ aDefaultFileName
)
Parameters
aFilter (String)
aDefaultFileName (String)
Return Value


SaveFile Method (aFilter, aDefaultFileName)

SaveFile Method (aFilter, aDefaultFileName)
Namespaces ► Devolutions.Utils ► WinFormsUtils ► SaveFile(String, String)
Select a file with a SaveFile dialog
Declaration Syntax
C# Visual Basic Visual C++
public static string SaveFile(
    string aFilter,
    string aDefaultFileName
)
Public Shared Function SaveFile ( _
    aFilter As String, _
    aDefaultFileName As String _
) As String
public:
static String^ SaveFile(
    String^ aFilter,
    String^ aDefaultFileName
)
Parameters
aFilter (String)
aDefaultFileName (String)
Return Value


TitleBarHeightDelta Property

TitleBarHeightDelta Property
Namespaces ► Devolutions.Utils ► WinFormsUtils ► TitleBarHeightDelta
Return the default Delta for the Title Bar size between Windows XP with Theme and Windows 2000. Windows 2000 is the baseline.
Declaration Syntax
C# Visual Basic Visual C++
public static int TitleBarHeightDelta { get; }
Public Shared ReadOnly Property TitleBarHeightDelta As Integer
public:
static property int TitleBarHeightDelta {
    int get ();
}
Return Value


TreeViewAutoScroll Method (aTreeView, e)

TreeViewAutoScroll Method (aTreeView, e)
Namespaces ► Devolutions.Utils ► WinFormsUtils ► TreeViewAutoScroll(TreeView, DragEventArgs)
Used to add an autoscroll behavior in a treeview when the user execute a drag and drop.
Declaration Syntax
C# Visual Basic Visual C++
public static void TreeViewAutoScroll(
    TreeView aTreeView,
    DragEventArgs e
)
Public Shared Sub TreeViewAutoScroll ( _
    aTreeView As TreeView, _
    e As DragEventArgs _
)
public:
static void TreeViewAutoScroll(
    TreeView^ aTreeView,
    DragEventArgs^ e
)
Parameters
aTreeView (TreeView)
e (DragEventArgs)


TreeViewContainsNode Method (aNode1, aNode2)

TreeViewContainsNode Method (aNode1, aNode2)
Namespaces ► Devolutions.Utils ► WinFormsUtils ► TreeViewContainsNode(TreeNode, TreeNode)
Return true if a treeview node contains an other node.
Declaration Syntax
C# Visual Basic Visual C++
public static bool TreeViewContainsNode(
    TreeNode aNode1,
    TreeNode aNode2
)
Public Shared Function TreeViewContainsNode ( _
    aNode1 As TreeNode, _
    aNode2 As TreeNode _
) As Boolean
public:
static bool TreeViewContainsNode(
    TreeNode^ aNode1,
    TreeNode^ aNode2
)
Parameters
aNode1 (TreeNode)
aNode2 (TreeNode)
Return Value


TreeViewDefaultDragOver Method (sender, e)

TreeViewDefaultDragOver Method (sender, e)
Namespaces ► Devolutions.Utils ► WinFormsUtils ► TreeViewDefaultDragOver(Object, DragEventArgs)
Default behavior for a drag over: a - auto open closed nodes - autoscroll
Declaration Syntax
C# Visual Basic Visual C++
public static void TreeViewDefaultDragOver(
    Object sender,
    DragEventArgs e
)
Public Shared Sub TreeViewDefaultDragOver ( _
    sender As Object, _
    e As DragEventArgs _
)
public:
static void TreeViewDefaultDragOver(
    Object^ sender,
    DragEventArgs^ e
)
Parameters
sender (Object)
e (DragEventArgs)


TreeViewDefaultItemDrag Method (sender, e)

TreeViewDefaultItemDrag Method (sender, e)
Namespaces ► Devolutions.Utils ► WinFormsUtils ► TreeViewDefaultItemDrag(Object, ItemDragEventArgs)
Default TreeView Default Item Drag.
Declaration Syntax
C# Visual Basic Visual C++
public static void TreeViewDefaultItemDrag(
    Object sender,
    ItemDragEventArgs e
)
Public Shared Sub TreeViewDefaultItemDrag ( _
    sender As Object, _
    e As ItemDragEventArgs _
)
public:
static void TreeViewDefaultItemDrag(
    Object^ sender,
    ItemDragEventArgs^ e
)
Parameters
sender (Object)
e (ItemDragEventArgs)


WMIUtils Class

WMIUtils Class
Namespaces ► Devolutions.Utils ► WMIUtils
This class contains some helper functions for WMI.
Declaration Syntax
C# Visual Basic Visual C++
public class WMIUtils
Public Class WMIUtils
public ref class WMIUtils
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | WMIUtils()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetPropertyFromWMI(String, String) | Return WMI property from a Query
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
WMIUtils


GetPropertyFromWMI Method (aSelect, aPropertyName)

GetPropertyFromWMI Method (aSelect, aPropertyName)
Namespaces ► Devolutions.Utils ► WMIUtils ► GetPropertyFromWMI(String, String)
Return WMI property from a Query
Declaration Syntax
C# Visual Basic Visual C++
protected static Object GetPropertyFromWMI(
    string aSelect,
    string aPropertyName
)
Protected Shared Function GetPropertyFromWMI ( _
    aSelect As String, _
    aPropertyName As String _
) As Object
protected:
static Object^ GetPropertyFromWMI(
    String^ aSelect,
    String^ aPropertyName
)
Parameters
aSelect (String)
aPropertyName (String)
Return Value


WMIUtils Constructor

WMIUtils Constructor
Namespaces ► Devolutions.Utils ► WMIUtils ► WMIUtils()()()
Declaration Syntax
C# Visual Basic Visual C++
public WMIUtils()
Public Sub New
public:
WMIUtils()


Devolutions.Utils.CommandLine Namespace

Devolutions.Utils.CommandLine Namespace
Namespaces ► Devolutions.Utils.CommandLine
Declaration Syntax
C# Visual Basic Visual C++
namespace Devolutions.Utils.CommandLine
Namespace Devolutions.Utils.CommandLine
namespace Devolutions.Utils.CommandLine
Types
All Types Classes
Icon Type Description
BaseCommandLineOption
Base class for all the command line options

BoolCommandLineOption
This class represents a switch command line option

CommandLineManager
Manage the command line option and is used to register and retreive option value. Proces must call to analyse the command line

ValueCommandLineOption
This class is used with a value command line. Ex /out:myfilename.xml
Examples
run.exe /out:myfilename.xml
  ValueCommandLineOption _OutputCommandLineOption = new ValueCommandLineOption(new string[] { "o:", "out:" });


BaseCommandLineOption Class

BaseCommandLineOption Class
Namespaces ► Devolutions.Utils.CommandLine ► BaseCommandLineOption
Base class for all the command line options
Declaration Syntax
C# Visual Basic Visual C++
public abstract class BaseCommandLineOption
Public MustInherit Class BaseCommandLineOption
public ref class BaseCommandLineOption abstract
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BaseCommandLineOption(String) | BaseCommandLineOption contructor.
 | BaseCommandLineOption(array<String>[]()[]) | BaseCommandLineOption contructor.
 | CaseSensitive | Indicate if the option is case sensitive or not
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSwitch(String) | Verify if a switch is supported by this switch
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(String) | Parse the switch and retreive the value if found
 | Switch | Return the first switch if more than one is supported. Otherwise it's return the switch
 | Switchs | Return the supported swith by this option. And option can support more than one switch.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseCommandLineOption
 |  | BoolCommandLineOption
 |  | ValueCommandLineOption


BaseCommandLineOption Constructor

BaseCommandLineOption Constructor
Namespaces ► Devolutions.Utils.CommandLine ► BaseCommandLineOption ► BaseCommandLineOption()()()
Members
Icon | Member | Description
 | BaseCommandLineOption(String) | BaseCommandLineOption contructor.
 | BaseCommandLineOption(array<String>[]()[]) | BaseCommandLineOption contructor.


BaseCommandLineOption Constructor (aSwitch)

BaseCommandLineOption Constructor (aSwitch)
Namespaces ► Devolutions.Utils.CommandLine ► BaseCommandLineOption ► BaseCommandLineOption(String)
BaseCommandLineOption contructor.
Declaration Syntax
C# Visual Basic Visual C++
protected BaseCommandLineOption(
    string aSwitch
)
Protected Sub New ( _
    aSwitch As String _
)
protected:
BaseCommandLineOption(
    String^ aSwitch
)
Parameters
aSwitch (String)


BaseCommandLineOption Constructor (aSwitchs)

BaseCommandLineOption Constructor (aSwitchs)
Namespaces ► Devolutions.Utils.CommandLine ► BaseCommandLineOption ► BaseCommandLineOption(array<String>[]()[])
BaseCommandLineOption contructor.
Declaration Syntax
C# Visual Basic Visual C++
protected BaseCommandLineOption(
    string[] aSwitchs
)
Protected Sub New ( _
    aSwitchs As String() _
)
protected:
BaseCommandLineOption(
    array<String^>^ aSwitchs
)
Parameters
aSwitchs (array< String >[]()[])


CaseSensitive Property

CaseSensitive Property
Namespaces ► Devolutions.Utils.CommandLine ► BaseCommandLineOption ► CaseSensitive
Indicate if the option is case sensitive or not
Declaration Syntax
C# Visual Basic Visual C++
public bool CaseSensitive { get; set; }
Public Property CaseSensitive As Boolean
public:
property bool CaseSensitive {
    bool get ();
    void set (bool value);
}


IsSwitch Method (aSwitch)

IsSwitch Method (aSwitch)
Namespaces ► Devolutions.Utils.CommandLine ► BaseCommandLineOption ► IsSwitch(String)
Verify if a switch is supported by this switch
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsSwitch(
    string aSwitch
)
Public Overridable Function IsSwitch ( _
    aSwitch As String _
) As Boolean
public:
virtual bool IsSwitch(
    String^ aSwitch
)
Parameters
aSwitch (String)
Return Value


Process Method (aParam)

Process Method (aParam)
Namespaces ► Devolutions.Utils.CommandLine ► BaseCommandLineOption ► Process(String)
Parse the switch and retreive the value if found
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool Process(
    string aParam
)
Public MustOverride Function Process ( _
    aParam As String _
) As Boolean
public:
virtual bool Process(
    String^ aParam
) abstract
Parameters
aParam (String)
Return Value


Switch Property

Switch Property
Namespaces ► Devolutions.Utils.CommandLine ► BaseCommandLineOption ► Switch
Return the first switch if more than one is supported. Otherwise it's return the switch
Declaration Syntax
C# Visual Basic Visual C++
public string Switch { get; }
Public ReadOnly Property Switch As String
public:
property String^ Switch {
    String^ get ();
}


Switchs Property

Switchs Property
Namespaces ► Devolutions.Utils.CommandLine ► BaseCommandLineOption ► Switchs
Return the supported swith by this option. And option can support more than one switch.
Declaration Syntax
C# Visual Basic Visual C++
public string[] Switchs { get; }
Public ReadOnly Property Switchs As String()
public:
property array<String^>^ Switchs {
    array<String^>^ get ();
}


BoolCommandLineOption Class

BoolCommandLineOption Class
Namespaces ► Devolutions.Utils.CommandLine ► BoolCommandLineOption
This class represents a switch command line option
Declaration Syntax
C# Visual Basic Visual C++
public class BoolCommandLineOption : BaseCommandLineOption
Public Class BoolCommandLineOption _
    Inherits BaseCommandLineOption
public ref class BoolCommandLineOption : public BaseCommandLineOption
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BoolCommandLineOption(String) | BoolCommandLineOption cosntructor.
 | BoolCommandLineOption(array<String>[]()[]) | BoolCommandLineOption cosntructor.
 | CaseSensitive | Indicate if the option is case sensitive or not (Inherited from BaseCommandLineOption.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Found | Return true if the switch is passed in parameter.
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSwitch(String) | Verify if a switch is supported by this switch (Inherited from BaseCommandLineOption.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(String) | Verify if the option is found in the command line options. (Overrides BaseCommandLineOption.Process(String).)
 | Switch | Return the first switch if more than one is supported. Otherwise it's return the switch (Inherited from BaseCommandLineOption.)
 | Switchs | Return the supported swith by this option. And option can support more than one switch. (Inherited from BaseCommandLineOption.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseCommandLineOption
 |  | BoolCommandLineOption


BoolCommandLineOption Constructor

BoolCommandLineOption Constructor
Namespaces ► Devolutions.Utils.CommandLine ► BoolCommandLineOption ► BoolCommandLineOption()()()
Members
Icon | Member | Description
 | BoolCommandLineOption(String) | BoolCommandLineOption cosntructor.
 | BoolCommandLineOption(array<String>[]()[]) | BoolCommandLineOption cosntructor.


BoolCommandLineOption Constructor (aSwitch)

BoolCommandLineOption Constructor (aSwitch)
Namespaces ► Devolutions.Utils.CommandLine ► BoolCommandLineOption ► BoolCommandLineOption(String)
BoolCommandLineOption cosntructor.
Declaration Syntax
C# Visual Basic Visual C++
public BoolCommandLineOption(
    string aSwitch
)
Public Sub New ( _
    aSwitch As String _
)
public:
BoolCommandLineOption(
    String^ aSwitch
)
Parameters
aSwitch (String)


BoolCommandLineOption Constructor (aSwitchs)

BoolCommandLineOption Constructor (aSwitchs)
Namespaces ► Devolutions.Utils.CommandLine ► BoolCommandLineOption ► BoolCommandLineOption(array<String>[]()[])
BoolCommandLineOption cosntructor.
Declaration Syntax
C# Visual Basic Visual C++
public BoolCommandLineOption(
    string[] aSwitchs
)
Public Sub New ( _
    aSwitchs As String() _
)
public:
BoolCommandLineOption(
    array<String^>^ aSwitchs
)
Parameters
aSwitchs (array< String >[]()[])


Found Property

Found Property
Namespaces ► Devolutions.Utils.CommandLine ► BoolCommandLineOption ► Found
Return true if the switch is passed in parameter.
Declaration Syntax
C# Visual Basic Visual C++
public bool Found { get; set; }
Public Property Found As Boolean
public:
property bool Found {
    bool get ();
    void set (bool value);
}


Process Method (aParam)

Process Method (aParam)
Namespaces ► Devolutions.Utils.CommandLine ► BoolCommandLineOption ► Process(String)
Verify if the option is found in the command line options.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Process(
    string aParam
)
Public Overrides Function Process ( _
    aParam As String _
) As Boolean
public:
virtual bool Process(
    String^ aParam
) override
Parameters
aParam (String)
Return Value


CommandLineManager Class

CommandLineManager Class
Namespaces ► Devolutions.Utils.CommandLine ► CommandLineManager
Manage the command line option and is used to register and retreive option value. Proces must call to analyse the command line
Declaration Syntax
C# Visual Basic Visual C++
public class CommandLineManager
Public Class CommandLineManager
public ref class CommandLineManager
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommandLineManager()()() |
 | CommandLineOptions | Return the list of command line options.
 | DefaultMessage | Default message if one or more command line option is invalid
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCommandLineOptionBySwitch(String) | Return a command line option for a specific switch.
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(array<String>[]()[]) | Process the command line options.
 | RegisterCommandLineSwitch(BaseCommandLineOption) | Register a supported command line option.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CommandLineManager


CommandLineManager Constructor

CommandLineManager Constructor
Namespaces ► Devolutions.Utils.CommandLine ► CommandLineManager ► CommandLineManager()()()
Declaration Syntax
C# Visual Basic Visual C++
public CommandLineManager()
Public Sub New
public:
CommandLineManager()


CommandLineOptions Property

CommandLineOptions Property
Namespaces ► Devolutions.Utils.CommandLine ► CommandLineManager ► CommandLineOptions
Return the list of command line options.
Declaration Syntax
C# Visual Basic Visual C++
public BaseCommandLineOption[] CommandLineOptions { get; }
Public ReadOnly Property CommandLineOptions As BaseCommandLineOption()
public:
property array<BaseCommandLineOption^>^ CommandLineOptions {
    array<BaseCommandLineOption^>^ get ();
}


DefaultMessage Property

DefaultMessage Property
Namespaces ► Devolutions.Utils.CommandLine ► CommandLineManager ► DefaultMessage
Default message if one or more command line option is invalid
Declaration Syntax
C# Visual Basic Visual C++
public string DefaultMessage { get; set; }
Public Property DefaultMessage As String
public:
property String^ DefaultMessage {
    String^ get ();
    void set (String^ value);
}


GetCommandLineOptionBySwitch Method (aSwitch)

GetCommandLineOptionBySwitch Method (aSwitch)
Namespaces ► Devolutions.Utils.CommandLine ► CommandLineManager ► GetCommandLineOptionBySwitch(String)
Return a command line option for a specific switch.
Declaration Syntax
C# Visual Basic Visual C++
public BaseCommandLineOption GetCommandLineOptionBySwitch(
    string aSwitch
)
Public Function GetCommandLineOptionBySwitch ( _
    aSwitch As String _
) As BaseCommandLineOption
public:
BaseCommandLineOption^ GetCommandLineOptionBySwitch(
    String^ aSwitch
)
Parameters
aSwitch (String)
Return Value


Process Method (aCommandLine)

Process Method (aCommandLine)
Namespaces ► Devolutions.Utils.CommandLine ► CommandLineManager ► Process(array<String>[]()[])
Process the command line options.
Declaration Syntax
C# Visual Basic Visual C++
public bool Process(
    string[] aCommandLine
)
Public Function Process ( _
    aCommandLine As String() _
) As Boolean
public:
bool Process(
    array<String^>^ aCommandLine
)
Parameters
aCommandLine (array< String >[]()[])
Return Value


RegisterCommandLineSwitch Method (aCommandLineOption)

RegisterCommandLineSwitch Method (aCommandLineOption)
Namespaces ► Devolutions.Utils.CommandLine ► CommandLineManager ► RegisterCommandLineSwitch(BaseCommandLineOption)
Register a supported command line option.
Declaration Syntax
C# Visual Basic Visual C++
public void RegisterCommandLineSwitch(
    BaseCommandLineOption aCommandLineOption
)
Public Sub RegisterCommandLineSwitch ( _
    aCommandLineOption As BaseCommandLineOption _
)
public:
void RegisterCommandLineSwitch(
    BaseCommandLineOption^ aCommandLineOption
)
Parameters
aCommandLineOption (BaseCommandLineOption)


ValueCommandLineOption Class

ValueCommandLineOption Class
Namespaces ► Devolutions.Utils.CommandLine ► ValueCommandLineOption
This class is used with a value command line. Ex /out:myfilename.xml
Examples
run.exe /out:myfilename.xml
  ValueCommandLineOption _OutputCommandLineOption = new ValueCommandLineOption(new string[] { "o:", "out:" });

Declaration Syntax
C# Visual Basic Visual C++
public class ValueCommandLineOption : BaseCommandLineOption
Public Class ValueCommandLineOption _
    Inherits BaseCommandLineOption
public ref class ValueCommandLineOption : public BaseCommandLineOption
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValueCommandLineOption(String) | Value command line option constructor.
 | ValueCommandLineOption(array<String>[]()[]) | Value command line option constructor.
 | CaseSensitive | Indicate if the option is case sensitive or not (Inherited from BaseCommandLineOption.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSwitch(String) | Return true if the switch is supported by this command line option. (Overrides BaseCommandLineOption.IsSwitch(String).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(String) | Parse the command line options to retreive values. (Overrides BaseCommandLineOption.Process(String).)
 | Switch | Return the first switch if more than one is supported. Otherwise it's return the switch (Inherited from BaseCommandLineOption.)
 | Switchs | Return the supported swith by this option. And option can support more than one switch. (Inherited from BaseCommandLineOption.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Values | Return the parsed values.
Inheritance Hierarchy
Object
 | BaseCommandLineOption
 |  | ValueCommandLineOption


IsSwitch Method (aSwitch)

IsSwitch Method (aSwitch)
Namespaces ► Devolutions.Utils.CommandLine ► ValueCommandLineOption ► IsSwitch(String)
Return true if the switch is supported by this command line option.
Declaration Syntax
C# Visual Basic Visual C++
public override bool IsSwitch(
    string aSwitch
)
Public Overrides Function IsSwitch ( _
    aSwitch As String _
) As Boolean
public:
virtual bool IsSwitch(
    String^ aSwitch
) override
Parameters
aSwitch (String)
Return Value


Process Method (aParam)

Process Method (aParam)
Namespaces ► Devolutions.Utils.CommandLine ► ValueCommandLineOption ► Process(String)
Parse the command line options to retreive values.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Process(
    string aParam
)
Public Overrides Function Process ( _
    aParam As String _
) As Boolean
public:
virtual bool Process(
    String^ aParam
) override
Parameters
aParam (String)
Return Value


ValueCommandLineOption Constructor

ValueCommandLineOption Constructor
Namespaces ► Devolutions.Utils.CommandLine ► ValueCommandLineOption ► ValueCommandLineOption()()()
Members
Icon | Member | Description
 | ValueCommandLineOption(String) | Value command line option constructor.
 | ValueCommandLineOption(array<String>[]()[]) | Value command line option constructor.


ValueCommandLineOption Constructor (aSwitch)

ValueCommandLineOption Constructor (aSwitch)
Namespaces ► Devolutions.Utils.CommandLine ► ValueCommandLineOption ► ValueCommandLineOption(String)
Value command line option constructor.
Declaration Syntax
C# Visual Basic Visual C++
public ValueCommandLineOption(
    string aSwitch
)
Public Sub New ( _
    aSwitch As String _
)
public:
ValueCommandLineOption(
    String^ aSwitch
)
Parameters
aSwitch (String)


ValueCommandLineOption Constructor (aSwitchs)

ValueCommandLineOption Constructor (aSwitchs)
Namespaces ► Devolutions.Utils.CommandLine ► ValueCommandLineOption ► ValueCommandLineOption(array<String>[]()[])
Value command line option constructor.
Declaration Syntax
C# Visual Basic Visual C++
public ValueCommandLineOption(
    string[] aSwitchs
)
Public Sub New ( _
    aSwitchs As String() _
)
public:
ValueCommandLineOption(
    array<String^>^ aSwitchs
)
Parameters
aSwitchs (array< String >[]()[])


Values Property

Values Property
Namespaces ► Devolutions.Utils.CommandLine ► ValueCommandLineOption ► Values
Return the parsed values.
Declaration Syntax
C# Visual Basic Visual C++
public string[] Values { get; }
Public ReadOnly Property Values As String()
public:
property array<String^>^ Values {
    array<String^>^ get ();
}


Devolutions.Utils Namespace

Devolutions.Utils Namespace
Namespaces ► Devolutions.Utils
Declaration Syntax
C# Visual Basic Visual C++
namespace Devolutions.Utils
Namespace Devolutions.Utils
namespace Devolutions.Utils
Types
All Types Classes Enumerations
Icon | Type | Description
 | ArrayUtils | This class contains the array utility functions.
 | AspNetUtils | This class contains the ASP.NET utility functions.
 | BinarySerializationUtils | This class contains the serialization utility functions.
 | DataSetUtils | This class contains dataset utility functions.
 | DateUtils | This class contains the date utility functions.
 | FileUtils | This class contains the file utility functions.
 | IISUtils | This class contains the IIS utility functions.
 | ImageUtils | This class contains the Image utility functions.
 | LogUtils | Basic file logger with multithreading support
 | OfficeUtils | This class contains the basic Office utility functions.
 | ReflectionUtils | This class contains the reflection utility functions.
 | RegistryUtils | This class contains the registry utility functions.
 | SerializationUtils | This class contains the serialization utility functions.
 | ServiceUtils..::.ServiceStart | This enum contains all the service start mode
 | ServiceUtils | This class contains the Window Service utility functions.
 | SqlClientUtils | This class contains the SqlServer utility functions.
 | StreamUtils | This class contains the stream utility functions.
 | StringUtils | This class contains the string utility functions.
 | SystemUtils | This class contains System utilities related to .Net or to the operating system.
 | WindowUtils | This class contains some Window Handle utility functions not related directly to WinForms.
 | WinFormsUtils | This class contains some Windows Form utility functions.
 | WMIUtils | This class contains some helper functions for WMI.